Help Needed - Clack WS-1 Brine Tank Full of Water, Messed Up Settings, and Other Issues

Users who are viewing this thread


New Member
Reaction score
Whitsett, NC
Hey everyone. Been reading the forums and learning a lot in trying to fix my water softener, but still no success. Hoping someone can help me get this thing working again.

Here is what I have, what I have done, and what I am experiencing.

* Clack WS1 (I'm pretty sure) valve
* 54" tank (says Empress 1054 on the tank)
* I believe it is a Water Right Impression series with a Clack valve

*Water softener was given free (so I knew nothing about it)
*It worked great for several years. We have really hard water. After a few years it stopped producing soft water and I noticed the brine tank full of water
* I addressed some of the things that would typically cause this issue - clogged injector, blocked drain line etc. Still not working.
* I finally decided to pull the valve apart and do a complete rebuild. It was FULL or orange sludge (iron?). I installed a new spacer stack assembly, brine piston and brine regenerant piston, new injector, new brine line elbow assembly, new float control elbow, and cleaned every inner part of the valve.
* I assumed it would work after this but no, it is still filling the brine tank.

In studying closer during some manual regen cycles, I discovered that the brine line was actually putting water into the brine tank DURING the down brine cycle ( a very strong stream, and no suction of brine). This seemed to me to be why the tank was full after every regen, and no soft water, but why it was happening was a mystery.

One thing I had done at the very beginning (which I regret) was screw around with the valve settings, and by the time I got done I didn't know what the original settings were so they could certainly be off, but I reset the valve settings as a DOWNFLOW brine cycle.

My settings now are: Backwash 8 min > Down Brine 60 min> Backwash 8min > Rinse 4min > Fill 6 min

When I rebuilt the valve I ordered the spacer stack assembly and piston for a DOWNFLOW system, because that's what I thought I needed, but now I am wondering is this actually an UPFLOW system?

The reasons I started thinking this may be an upflow system are these:

1) There is a sticker on the top of the valve that just says: UP. (see image)
2) On page 4 of the Clack service manual it says an upflow system (in the injector port) will have a hole labeled UP, and an unlabeled hole - which I have (see image)

So, to test I changed the injector and plug as stated for an UPFLOW system, and changed the down brine setting to up brine and ran through the brine cycle. The only thing I noticed differently after it was complete was that it was no longer adding water to the brine tank during the brine cycle. IF it was actually drawing brine I could not tell. But in any case after the regen cycle there's no soft water, and it certainly didn't draw all the water out of the brine tank.
I know I am missing something vital here, and it is due to lack of knowledge and experience with water softeners.
I hope the information I have given along with the pictures will help someone see what I am doing wrong and lead my in the right direction to get this thing working again. |
Thanks for reading and any help is appreciated.
Hey, wait a minute.

This is awkward, but...

It looks like you're using an ad blocker. We get it, but (1) can't live without ads, and (2) ad blockers can cause issues with videos and comments. If you'd like to support the site, please allow ads.

If any particular ad is your REASON for blocking ads, please let us know. We might be able to do something about it. Thanks.
I've Disabled AdBlock    No Thanks