Roman tub with Delta faucet has no hot water.

Users who are viewing this thread

GrapefruitGorilla

New Member
Messages
2
Reaction score
0
Points
1
Location
Canada
I have a delta R2700 it’s about 10 years old. I changed the cartridge and nothing. There is access from the side and I can see two pex lines hot and cold coming into the faucet. I don’t see any mixing valve. Im not sure if it needs one or it’s located somewhere else? The bathroom has this tub, a walk in shower, 2 basins and a toilet. Does it have anything to do with the other fixtures? Someone told me to change the cartridge in the shower, I’m not sure what they have to do with each other. Also there is full pressure on both sides. Any ideas before I break the tiles? Thanks.
 

Jeff H Young

In the Trades
Messages
9,194
Reaction score
2,316
Points
113
Location
92346
I have a delta R2700 it’s about 10 years old. I changed the cartridge and nothing. There is access from the side and I can see two pex lines hot and cold coming into the faucet. I don’t see any mixing valve. Im not sure if it needs one or it’s located somewhere else? The bathroom has this tub, a walk in shower, 2 basins and a toilet. Does it have anything to do with the other fixtures? Someone told me to change the cartridge in the shower, I’m not sure what they have to do with each other. Also there is full pressure on both sides. Any ideas before I break the tiles? Thanks.
can you be a little more clear what happened ?
 
Top
Hey, wait a minute.

This is awkward, but...

It looks like you're using an ad blocker. We get it, but (1) terrylove.com can't live without ads, and (2) ad blockers can cause issues with videos and comments. If you'd like to support the site, please allow ads.

If any particular ad is your REASON for blocking ads, please let us know. We might be able to do something about it. Thanks.
I've Disabled AdBlock    No Thanks