Water softener using salt but not softening...

Users who are viewing this thread


New Member
Reaction score
Ok, so I have super hard water at my house (95gpg) and I have a water softener feeding a whole house RO system (150G tank with a separate pump to feed domestic water). The whole setup is about 4 years old, just before I purchased the house.

Last fall, I replaced the resin because I thought it was cooked because it wasn't softening correctly. Worked nice for a bit, but now it's not softening again. It's using salt, I cleaned the control head out, and it seems to be working properly. I didn't taste any salt in the discharge during the brine draw cycle, etc - but it's still not softening as well as it should (it's coming out at 800+ppm).

Should I replace the spacer stack? What about the piston? I pulled it all apart and it appears to be in good condition, however the orings felt a bit hard.

At a bit of a loss as to what I should do next...



Well-Known Member
Reaction score
Ontario, Canada
You haven't provided many details.

- Water softener control valve brand and model?
- Total quantity of resin or the total hardness removal capacity for the softener?
- Current settings programmed?
- Municipal supplied or Private well water?
- If private well supply, iron and/or manganese quantity if any?
- Number of occupants or quantity of water consumed per month?

it's still not softening as well as it should (it's coming out at 800+ppm)
How was the 800 ppm determined (method or test type)?
Hey, wait a minute.

This is awkward, but...

It looks like you're using an ad blocker. We get it, but (1) terrylove.com can't live without ads, and (2) ad blockers can cause issues with videos and comments. If you'd like to support the site, please allow ads.

If any particular ad is your REASON for blocking ads, please let us know. We might be able to do something about it. Thanks.
I've Disabled AdBlock    No Thanks