Navien 240a help needed

Users who are viewing this thread


New Member
Reaction score
Truckee, ca
I just had a plumber install a Navien NPE-240a2 tankless water heater and am now having multiple issues with it. The plumber can't come take a look at it again until next week so here I am trying to diagnose it myself with no luck so far.

Here is what is going on:
1. As soon as the new unit was installed I got low water pressure on the Hot side of all of my fixtures in the house. I have tried to switch between internal and external pump, recirculation on always and on 'intelligent' mode. Nothing makes a difference. I have cleaned out the filter in the Navien unit, it had some debris in it but not enough to do much. No improvement.

2. Recirculation not working
At first the recirculation was working, but now after I messed around with it the recirculation does not work. I have done a factory reset and put all of the settings back to where they were before I touched it. Still not working.

Background/History: I built a garage and had my old water heater (navien tankless) replaced and the water heater location was changed from under the house to the garage. Garage is a little further away 20' from the house and a little lower 8'. My street water pressure is 55psi. All my plumbing is 3/4" but the street pluming is 1/2" (old system that they are in the process of upgrading)

The new water heater reads 6-8psi when a fixture is open and hot water is being used. This seems very low to me, but I am unsure of where/how to check or troubleshoot this problem.

Navien Co. has been no help, they won't speak with me since I am not a licensed plumber

Any help or suggestions would be appreciated. Thank you!
Hey, wait a minute.

This is awkward, but...

It looks like you're using an ad blocker. We get it, but (1) can't live without ads, and (2) ad blockers can cause issues with videos and comments. If you'd like to support the site, please allow ads.

If any particular ad is your REASON for blocking ads, please let us know. We might be able to do something about it. Thanks.
I've Disabled AdBlock    No Thanks