Hunter Relay Not Engaging

Users who are viewing this thread

HistoricMustang

New Member
Messages
1
Reaction score
0
Points
1
Location
Savannah, Georgia
Need some help and I know very little about electricity. My Hunter irrigation system is not automacticly pumping water from in ground pump.

Installed a new Hunter relay that is providing the necessary 24 volts incoming to the relay but the relay is not engaging to activate pump. I also installed a new Franklin pump controller.

My question is why will the incoming 24 volts not activate the relay?

I have been able to manually activate the pump by using a piece of wood to activate the relay and pump water to sprinkler zones.

Could there be an issue with underground wires going to and coming from relay? Could it possibily be a "weak" transformer in the Hunter Controller?

Thanks in advance.
 

WorthFlorida

The wife is still training me.
Messages
5,057
Reaction score
806
Points
113
Location
Orlando, Florida
For some reason several posts from Aug1st - 8th, 2022 just showed up.

The relay is not working because it doesn't have 24v's. The controller has a MV terminal that gets wired to the relay. Check voltage there.
 
Top
Hey, wait a minute.

This is awkward, but...

It looks like you're using an ad blocker. We get it, but (1) terrylove.com can't live without ads, and (2) ad blockers can cause issues with videos and comments. If you'd like to support the site, please allow ads.

If any particular ad is your REASON for blocking ads, please let us know. We might be able to do something about it. Thanks.
I've Disabled AdBlock    No Thanks