Toilet fill valve making continuous hissing sound

Users who are viewing this thread

Theyegis

New Member
Messages
2
Reaction score
0
Points
1
Location
Maine
Hi all. First time poster here so apologies for any mistakes. My fill valve has recently started to make a pretty steady hissing sound, even when not flushing. Here's the link to two videos to demonstrate this: https://photos.app.goo.gl/PWm9YaDQHqiWmTzo6.

In the shorter one, you can even see a little water movement where the grey cylinder meets the black. Anyone know what could be wrong?
 

jadnashua

Retired Defense Industry Engineer xxx
Messages
32,753
Reaction score
1,171
Points
113
Location
New England
That model has an easily replaceable seal assembly, costs about $3, but here's some help on verifying what's wrong. https://www.fluidmaster.com/toilet-problems/toilet-running-constantly/

98% of the time, that fixes the problem. Yes, you can replace the whole valve, but it rarely is needed. You don't usually buy a new car because you need new tires...this is a common, but easily resolved problem.
 

Theyegis

New Member
Messages
2
Reaction score
0
Points
1
Location
Maine
That model has an easily replaceable seal assembly, costs about $3, but here's some help on verifying what's wrong. https://www.fluidmaster.com/toilet-problems/toilet-running-constantly/

98% of the time, that fixes the problem. Yes, you can replace the whole valve, but it rarely is needed. You don't usually buy a new car because you need new tires...this is a common, but easily resolved problem.
Thanks for the reply. You're talking about replacing this part, right? https://www.amazon.com/Fluidmaster-...&sprefix=fluidmaster+valve+sea,aps,264&sr=8-2
 
Top
Hey, wait a minute.

This is awkward, but...

It looks like you're using an ad blocker. We get it, but (1) terrylove.com can't live without ads, and (2) ad blockers can cause issues with videos and comments. If you'd like to support the site, please allow ads.

If any particular ad is your REASON for blocking ads, please let us know. We might be able to do something about it. Thanks.
I've Disabled AdBlock    No Thanks