Pump Saver Plus - Questions

Users who are viewing this thread

bigballer

New Member
Messages
10
Reaction score
0
Points
1
Location
Seattle, WA
I replaced the float switch which was cracked and thought my problem was solved but 2 days later I had the same rapid cycling error lights come on. I am going to replace the pump saver switch next, hopefully that WILL solve the problem.

i know this is old but the last 2 days i have been fighting the same issue with what sounds like an almost identical setup. did you end up replacing the pumpsaver and did it fix the problem?

my cistern was empty yesterday found the calibration light flashing red, reset the power, recalibrated and the pump came on, filled up and went to bed. around 2pm today no water.. go check and tank is empty - 500gallon tank. repeat procedure from yesterday now its in the "calibrating" stage - ie both run and cal lights solid green but filling the tank. i am not sure if it ever drops out of that i'll have to check on it in a bit and see whats happening.. how long is the calibration stage supposed to last before it turns to normal operating mode?
 

Valveman

Cary Austin
Staff member
Messages
13,578
Reaction score
1,032
Points
113
Location
Lubbock, Texas
Website
cyclestopvalves.com
Calibration should be fairly quick. If you are going to replace it look at a Cycle Sensor instead, ad it is much easier to calibrate and to see what is happening.
 

Petesbath

New Member
Messages
4
Reaction score
0
Points
1
Location
California
i know this is old but the last 2 days i have been fighting the same issue with what sounds like an almost identical setup. did you end up replacing the pumpsaver and did it fix the problem?

my cistern was empty yesterday found the calibration light flashing red, reset the power, recalibrated and the pump came on, filled up and went to bed. around 2pm today no water.. go check and tank is empty - 500gallon tank. repeat procedure from yesterday now its in the "calibrating" stage - ie both run and cal lights solid green but filling the tank. i am not sure if it ever drops out of that i'll have to check on it in a bit and see whats happening.. how long is the calibration stage supposed to last before it turns to normal operating mode?
Did you fix your problem
 
Top
Hey, wait a minute.

This is awkward, but...

It looks like you're using an ad blocker. We get it, but (1) terrylove.com can't live without ads, and (2) ad blockers can cause issues with videos and comments. If you'd like to support the site, please allow ads.

If any particular ad is your REASON for blocking ads, please let us know. We might be able to do something about it. Thanks.
I've Disabled AdBlock    No Thanks