How to enable Navicirc with Navien 240A2

Users who are viewing this thread

Ahg2003

New Member
Messages
2
Reaction score
0
Points
1
Location
Livermore
We have Navien 240A2 and I have just purchased navicirc. Navicirc installation manual has an instruction to turn ON option "P17 - Enable thermal bypass valve". I don't see that option on 240A2. Is there any updated navicirc installation document for 240A2. Even steps to enable R&D menu is incorrect.

BTW, I have also got Navilink. Are there any good instructions/video to set that up.

Edit: I just have the cold and hot water connections to Navien, no tee from the cold line to the recirc port. I read in couple of posts here and saw one line diagram that tee is not needed for 240A2. Can someone please confirm that's correct.

Thanks.
 
Last edited:

Breplum

Licensed plumbing contractor
Messages
1,162
Reaction score
444
Points
83
Location
San Francisco Bay Area
1667715227585.png
 

Ahg2003

New Member
Messages
2
Reaction score
0
Points
1
Location
Livermore
Thanks for the line diagram, that's how its connected right now. Looks like with 240A2, we don't have to enable thermal bypass valve. I have the switch inside the unit set to external and in the menu, recirculation type is set to external. It seems to be working fine.

Our unit is outside and I'm wondering how is everyone running the cable for Navilink from the unit to inside? Is there an outside enclosure available for Navilink unit which can house it.
 
Top
Hey, wait a minute.

This is awkward, but...

It looks like you're using an ad blocker. We get it, but (1) terrylove.com can't live without ads, and (2) ad blockers can cause issues with videos and comments. If you'd like to support the site, please allow ads.

If any particular ad is your REASON for blocking ads, please let us know. We might be able to do something about it. Thanks.
I've Disabled AdBlock    No Thanks