Search results

  1. L

    navien npe 240A Not circulating. Tested and replaced multiple parts. But still nothing.

    I didn't open the siphon after I replaced the pump, I'll have to look how to do that, any suggestions. I did bleed the air out of the pump by running a pump test and opening and closing the drain on the bottom of the pump and the front of the pump many times. When I talked to the tech this was...
  2. L

    navien npe 240A Not circulating. Tested and replaced multiple parts. But still nothing.

    I had the same thought. I replaced the pump 2 times. And when I plug it into the power line to test it, it spins up. So there must be something in the system that tells it not to engage. Thanks though!
  3. L

    navien npe 240A Not circulating. Tested and replaced multiple parts. But still nothing.

    I wonder if I should dive into the parameters and try and get the pump to circulate more often. I also am wondering the 240a thinks there is an external pump. Has anyone messed with parameters?
  4. L

    navien npe 240A Not circulating. Tested and replaced multiple parts. But still nothing.

    Welp, I’ve replaced the Syphon and have the dip switche 2 set to on and the valve set to EXT. When I run the pump test I get less than a GPM. Still the same issue with no instant hot water. With this issue being caused by a freeze I am afraid there are other parts I can’t see that are broken. No...
  5. L

    navien npe 240A Not circulating. Tested and replaced multiple parts. But still nothing.

    Update. I was taking pics of the dip switches and valve settings and saw some drips. Found that the siphon behind the pump has two big cracks in it. Ordered new siphon. Thinking the cracks are allowing air into the system so the pump can’t create enough pressure to circulate properly. Just a...
  6. L

    navien npe 240A Not circulating. Tested and replaced multiple parts. But still nothing.

    So far I have not replaced the two valves. Only the pump and the pcb board. But I think that was overkill. It sounds like there is no need to replace the parts. But then I am back where I started with a non recirculating heater with a working pump and valves and dip switches set correctly. Open...
  7. L

    navien npe 240A Not circulating. Tested and replaced multiple parts. But still nothing.

    This is awesome. I’ll reset the unit so the valve is set to ext(vertical) and make sure dip switch 2 is on. I am willing to replace check valve I was also thinking of replacing the water adjustment valve. What do think of the replacements? I’m just running out of things to check.
  8. L

    navien npe 240A Not circulating. Tested and replaced multiple parts. But still nothing.

    I can get it to turn on when I test it so yes it does run. As far as normal operation no I don’t believe it turns on. As far as I know there are no check valves outside of the one inside the hot water heater. Happy to keep answering questions and thanks for the reply.
  9. L

    navien npe 240A Not circulating. Tested and replaced multiple parts. But still nothing.

    Hi, I have an navien npe 240A on city water, with a recirculating line. It went through a freeze back in early 2023. I replaced the pump because it was cracked. Ever since then the water in the house takes a long time to heat up and the water pressure seems low. I recently got fed up with this...
  10. L

    Low water pressure after a freeze

    Hi, Thanks for thoughts. I had similar concerns so I checked and cleaned all the filters. There is no scaling or build up in the pump or flow sensor, and the unit is just about two years old so I don’t think it is build up. The pressure coming to the unit from the city seems to be good but I...
  11. L

    Low water pressure after a freeze

    Hi all, I have a Nevian NPE-240A NG with a recirculating line. We recently had a freeze and despite turning my water off and draining my pipes and water heater the plastic part of the pump housing cracked in the water heater. I replaced the pump and everything is working well except my water...
Top
Hey, wait a minute.

This is awkward, but...

It looks like you're using an ad blocker. We get it, but (1) terrylove.com can't live without ads, and (2) ad blockers can cause issues with videos and comments. If you'd like to support the site, please allow ads.

If any particular ad is your REASON for blocking ads, please let us know. We might be able to do something about it. Thanks.
I've Disabled AdBlock    No Thanks