(206) 949-5683, Top Rated Plumber, Seattle
Results 1 to 2 of 2

Thread: J-Class Well Water Pump S1CY-S Not Pumping Water

  1. #1
    DIY Junior Member
    Join Date
    Apr 2013
    Location
    Vero Beach FL
    Posts
    1

    Default J-Class Well Water Pump S1CY-S Not Pumping Water

    Hi All,

    Recently we noticed our water pump had a minor leak. Before we could fix the leak the pump stopped pumping all together. We have since sealed all the leaks but this did not resolve the problem. What is happening is the pump will turn on for about 30 seconds and then it shuts off. We noticed the pump itself was very hot. Do you know anything about the insides of the pump and what could be going on?

  2. #2
    Jack of all trades DonL's Avatar
    Join Date
    Mar 2011
    Location
    Houston, TX
    Posts
    3,645

    Default

    Quote Originally Posted by dfannin View Post
    Hi All,

    Recently we noticed our water pump had a minor leak. Before we could fix the leak the pump stopped pumping all together. We have since sealed all the leaks but this did not resolve the problem. What is happening is the pump will turn on for about 30 seconds and then it shuts off. We noticed the pump itself was very hot. Do you know anything about the insides of the pump and what could be going on?

    Not sure what kind of leak you had, pump seal or what ?

    If water got into the Start Switch it could be stuck in start or not making contact.

    Does it pump water ?

    You could have a bad run capacitor also.

    It you replaced the pump seal, then the Impeller could be out of center alignment and rubbing on the pump housing.


    Good Luck
    Theory only works perfect in a vacuum.

    Cyber Security Protection for Windows C:\ > WWW.WinForce.Net

Similar Threads

  1. Low Water Pressure Woes! Pumping city water up a hill
    By ren451 in forum Pumps and Tanks Well Forum & Blog
    Replies: 17
    Last Post: 04-02-2013, 06:46 AM
  2. Sump pump going on every minute in heavy rain (but pumping water)
    By dexys in forum Pumps and Tanks Well Forum & Blog
    Replies: 2
    Last Post: 09-08-2011, 04:18 PM
  3. water softener is not pumping water into brine tank.
    By crabby in forum Water Softener Forum, problems, installation and reviews
    Replies: 3
    Last Post: 01-20-2010, 08:31 PM
  4. Quiet pump for pumping water from a concrete storage tank in the basement
    By luc in forum Pumps and Tanks Well Forum & Blog
    Replies: 6
    Last Post: 04-29-2009, 10:40 AM
  5. well pump pumping water into tank continuously
    By Yvonne58 in forum Pumps and Tanks Well Forum & Blog
    Replies: 1
    Last Post: 07-24-2007, 12:26 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •