(206) 949-5683, Top Rated Plumber, Seattle
Results 1 to 3 of 3

Thread: Sump pump wont start

  1. #1
    DIY Junior Member pumpnewbie's Avatar
    Join Date
    Mar 2013
    Location
    British Columbia
    Posts
    2

    Default Sump pump wont start

    Yesterday I used my Liberty sump pump model s35 (spec sheet: http://www.paulsupply.com/files/LibertyS35.pdf )
    and it was working great. I had plugged it manually and forgot. About 4 hours later, I remembered that the pump was still powered on. The water had been completely drained and I think that the pump had been still running for about 3 hours or so thereafter with no water left. I noticed that the motor had stopped. I tried to re-plug it to restart but it wont start. I waited some hours because it has thermal protection but it still wont start.
    This morning I put the pump in a large bucket and filled it full with water since the pump has a Automatic Diaphragm Switch built into the pump. Nothing. The motor didn't even hum.


    Is it possible that the motor burnt out? Is there anything that I should try to get it going again? The power outlet is fine. I dont know the 1st thing about mechanics but hope the pump can work again. help

  2. #2
    Test, Don't Guess! cacher_chick's Avatar
    Join Date
    Jan 2008
    Location
    Land of Cheese
    Posts
    3,154

    Default

    It's a submersible pump which should never be run without water flowing through it.
    Unless you are very lucky, it is ready for the scrap pile.

  3. #3
    DIY Junior Member pumpnewbie's Avatar
    Join Date
    Mar 2013
    Location
    British Columbia
    Posts
    2

    Default

    I thought the motor was dead but yesterday I plugged the sump pump into the outlet and I could hear the motor lightly humming (the pump was not in water I was trying it one last time before chucking it and then this low hum... ) so now I don't know whether it can work again or ... ?

Similar Threads

  1. pump wont turn on
    By tressie in forum Pumps and Tanks Well Forum & Blog
    Replies: 1
    Last Post: 07-22-2012, 07:20 AM
  2. pump wont come on
    By jrmcmil in forum Pumps and Tanks Well Forum & Blog
    Replies: 28
    Last Post: 01-18-2009, 06:54 PM
  3. Reputation of ABS Robusta sump pump / sump pump configuration issues
    By ct-esq in forum Pumps and Tanks Well Forum & Blog
    Replies: 2
    Last Post: 12-29-2008, 06:41 AM
  4. lennox pulse g14Q3 wont start
    By possum in forum HVAC Heating & Cooling
    Replies: 1
    Last Post: 10-22-2008, 06:22 AM
  5. Well pump wont prime
    By mifirecop in forum Pumps and Tanks Well Forum & Blog
    Replies: 18
    Last Post: 06-25-2007, 10:45 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •