Never had a water softener but the house we bought had one but it was broken. We just had the plumber replumb and install a Aqua Pure CWS200ME which is a 2 tank system where the salt is in a separate holding tank. The valve is a rebranded Clack valve. The plumber hooked it all up and I put salt in it and started the recharge. I neglected to put water in it so the first charge really did not do anything I guess. I put water in it and let it recharge at 2am. The next morning a good portion of the 40 pounds of was gone and the water level looks like it was shut off at the top of the tank hitting the float. I recharged it again last night and had put another 40 pounds in and it did not appear that it pulled any brine from the tank. If it did, it was very very little. So of course at the end it tried to refill the brine tank with water but it was still full and the float again stopped the water. So basically I have a brine tank full of water and none or very little is going into the resin tank. The hose between them was not real tight so I saw water drip out of the end on the valve but that was it. It is set for 12 pound of salt and the resin wash was set for 7 minutes so I am guessing that would be approximately 4 gallons of brine water had it actually worked. This is the 3M branded so they had default settings on the system and I have not changed any other than my hardness was bumped to 22. Since it's brand new I am not sure where to start. The valve makes noise and it appears everything else in the system functions including the draining and refill. Any suggestions on what I can try to get it running? Any help would be appreciated. The plumber did not know where to start.