Greetings all, I normally post in the home remodel section but this doesn't seem to apply to me trying to fix something broken in my house (for once!). But I'm not sure if this is the best forum--so I'm looking for advice and/or a better place to post this.

Since we moved in to our house we have had a ETQ generator (7250 watt model) that says "neutral bonded to frame" on it. I installed a GenTran 3028 manual transfer switch and hooked all my important circuits up to it.

When the power is out, everything works great. All our circuits will run from the generator and life is great. We've got sat TV, wireless, well pump, master bedroom, kitchen, etc.. all great. The Furnace, however, will not kick over. It "clicks" a couple of times and attempts to start the fan but it stops about a half second after that. Then it clicks and tries it again and fails the same way. So on and so on. I tried it with nothing else powered on except its breaker in the transfer switch and same deal--loaded or not loaded I got the same results.

I've been reading a lot of posts about neutral bonding and sine waves and all that junk but it kind of mystifies me (as this generator touts its "Clean Sine Alternator Technology"). One thing I did try was to run an extension cord straight from the outlet on the generator and plug the furnace right into it. It does the same thing and when it's plugged into the circuit running in the manual transfer switch.

As a test I brought down my battery backup/UPS and tried to connect that to the extension cord and the furnace to the UPS. On the surge only side it did the same thing it had been doing. On the battery side it would get "further" in the process (like the fan started to spin up) but then shut off and try again.

So I'm kind of stumped. Anyone have any ideas? Things I can try?

Also I should mention that when trying the extension cord only maneuver I did not have anything connected from the "grounding point" nub on the generator to anything--and the 30A cord that runs from the generator to the transfer switch was NOT plugged in--it was just straight up Generator sitting on my deck with an extension cord running to the Furnace.

My Furnace is a Lennox Elite Series G26Q3-75-3.and my UPS is a Cyberpower Pure Sine Wave CP1350PFCLCD.