(206) 949-5683, Top Rated Plumber, Seattle
Results 1 to 4 of 4

Thread: Need advice badly, pump won't prime

  1. #1
    DIY Junior Member JM1010's Avatar
    Join Date
    Apr 2012
    Location
    Ontario
    Posts
    7

    Default Need advice badly, pump won't prime

    TO Mr Texas Wellman and other pump expert, please help me!!

    I've exhausted pretty much everything I can think of to get water back and if I can't resolve my problem I am left with digging a well which I'd like to avoid.

    Our lake 2 line jet pump lost it's prime twice recently. So we changed the foot valve, ejector and were told to replace the pump which we did too. We cleaned everything good, even the lines. Checked all the fittings for leak etc. I filled the lines going to the lake by unscrewing at the pump so I know they are full of water.

    Still pump won't prime. When I connect a hose to my neighbor faucet I get pressure (50 psi). But as soon as I close it off and I try to prime pressure goes back to zero. I checked the tank and it is holding 28 psi so I assume that's good.

    The only weird thing is with both lines disconnected at the pump I get no water leaking through those holes when connected to my neighbor (ext. faucet to ext. faucet). Is that normal?? There is no check valve between the pump and the house piping.

    So either the new gould pump is bad or there is a leak in the 2 lines. I find it hard to believe that the line would break 4 feet down in the ground... And everything was working two weeks ago....


    Really don't know what to do... very depressed living without water.... Any idea what I should do next?

    Thanks in advance

    Jean

  2. #2
    In the Trades Texas Wellman's Avatar
    Join Date
    Feb 2010
    Location
    SE Texas-Coastal
    Posts
    487

    Default

    Lines break, even 4 ft down. It just makes it harder.

    Pictures would be a great help, but here are your options:

    You've got a air bubble in the twin line setup that is hard to get out. What happens when you put water in the smaller pipe (drive pipe)? You should get water all the way back through the suction pipe, which will be the larger one. If they are both the same size just try to flush water through both of them.

    You could have trash in your jet, but it should still pump, just no pressure.

    Doubtful your pump is bad, but I suppose it's possible. What is the model #?

    The footvalve could be stuck shut or open. I'm unsure what you mean by "won't prime". Sometimes they will prime but won't pick up or pump, and sometimes they just simply will not prime and stay full of water.

    Also there could be an in-line check valve somewhere in the buried line.

    When you say you can't get water out of the two holes do you mean when the tank side is pressured up no water comes out of the back of the pump where the two lines are? The pump might have a regulator on it and sometimes they won't let water back into the pump. Try pouring water directly into where the gauge is until full.

    Good luck!!

  3. #3
    DIY Junior Member JM1010's Avatar
    Join Date
    Apr 2012
    Location
    Ontario
    Posts
    7

    Default

    Thank you Mr Texas Wellman. Really appreciate you took the time to help me out here!

    I actually got lucky and found a leak at a pipe connection in the lake vs 4 feet down in the soil!!! Problem solved!!! Got water!!!

    You really have to experience having no water for a while to truly appreciate it!

    Best to all

    Jean

  4. #4
    DIYer, not in the trades LLigetfa's Avatar
    Join Date
    Feb 2011
    Location
    NW Ontario, Canada
    Posts
    3,681

    Default

    Quote Originally Posted by JM1010 View Post
    You really have to experience having no water for a while to truly appreciate it!
    BTDT
    Not so bad having a lake nearby. Try hauling water from miles away.

Similar Threads

  1. Pipe burst! CPVC, to prime or NOT to prime? What went wrong?
    By Sincraft in forum Plumbing Forum, Professional & DIY Advice, Tips & Tricks
    Replies: 10
    Last Post: 02-27-2012, 08:06 PM
  2. Pump Won't Prime or hold prime
    By PAmom1991 in forum Pumps and Tanks Well Forum & Blog
    Replies: 6
    Last Post: 05-31-2011, 07:09 AM
  3. Pump lost prime - won't prime (long post)
    By BWFRJR in forum Pumps and Tanks Well Forum & Blog
    Replies: 2
    Last Post: 08-30-2010, 06:37 PM
  4. advice needed, I can't prime the pump
    By rbig in forum Pumps and Tanks Well Forum & Blog
    Replies: 7
    Last Post: 04-30-2010, 10:47 AM
  5. 3 year old well pump motor case corroded so badly it seized up?
    By blown in forum Pumps and Tanks Well Forum & Blog
    Replies: 26
    Last Post: 07-27-2008, 06:49 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •