(206) 949-5683, Top Rated Plumber, Seattle
Results 1 to 7 of 7

Thread: Culligan MARK 100 PROBLEM

  1. #1
    DIY Junior Member Leonel's Avatar
    Join Date
    Feb 2012
    Location
    new hampshire
    Posts
    3

    Default Culligan MARK 100 PROBLEM

    Hi, i have this Culligan Mark 100, that is not working properly, failed to delivery softwater.
    when i press the REGEN twice, the clock turn and that it, not water comming out of the drain hose, it seen like is not sucking the water from the brine tank. today i checked the tank where the salt is and there is more water than salt.A lot more water than salt.
    on the back of the unit there is the valve one says Press for soft water and the other end Press to By Pass
    is on press for softwater
    What could be the problem, i clean the salt tank like 4 days ago.


  2. #2
    That's all folks! Gary Slusser's Avatar
    Join Date
    Aug 2004
    Location
    Wherever I park the motorhome.
    Posts
    6,790

    Default

    A blocked or frozen drain line would cause not water flow through the drain line. That would prevent any suction of brine water from the salt tank and when the softener went into regeneration, no water would be sucked out of the salt tank and then more water would be added by the refill position of the regeneration. It will continue to add water until it overflows or a float stops it.

    With no salt water being used, the resin will not be regenerated. So when you get water flowing out the drain line let it use the water is in the salt tank instead of emptying any out of it.
    Gary Slusser Retired (= out of business)
    Click Here to learn how to correctly size or program a water softener.
    CAUTION, as of Nov 12 2013 all YouTube videos showing how to rebuild a Clack valve have an error in them that can cause damage.

  3. #3
    In the Trades Akpsdvan's Avatar
    Join Date
    Dec 2009
    Location
    Alaska
    Posts
    1,464

    Default

    It will also add water to the brine or salt tank in the brine draw part of the cycle if the drain line is plugged by either Ice or some of form of block.

    Could be that some thing has blocked the flow plug that culligan uses it is some 5x thicker than the fleck drain flow controls and is very easily plugged.

    Put the unit in bypass or the red end in and with a towel cover the area where the drain line is held by a metal clip.. left side or same side as brine line, pull that pin and if there was a plug the water should clear it and the flow control out once that pin is removed.

  4. #4
    DIY Junior Member Leonel's Avatar
    Join Date
    Feb 2012
    Location
    new hampshire
    Posts
    3

    Default

    here is my follow up:
    i did remove the drian line, water came out clear
    remove the three screws on top of the unit, i cleaned the screen, clear water came out of the part.

    what else should I check for, what else should i remove or clean.
    in the next post i will post some images of the unit.
    thanks for the help.

  5. #5
    In the Trades Akpsdvan's Avatar
    Join Date
    Dec 2009
    Location
    Alaska
    Posts
    1,464

    Default

    If there is no water going out the drain line at the end, then there is some form of block in that line and it needs to be check for a block so that it can be cleared.
    The unit needs some place to put the water when in a cleaning cycle.

  6. #6
    DIY Junior Member Leonel's Avatar
    Join Date
    Feb 2012
    Location
    new hampshire
    Posts
    3

    Default Follow up

    Suddenly started to work just fine, i think it was something clog in the drain line.
    water feel soft, and the whole family is happy again.
    thanks a lot for all the input.

  7. #7
    In the Trades Akpsdvan's Avatar
    Join Date
    Dec 2009
    Location
    Alaska
    Posts
    1,464

    Default

    You might wish to walk the drain line to make sure that there is not a place that can freeze or has a bend that will stop the water in the future, if it has happened once it will happen again.

Similar Threads

  1. Would it be ok to install a used Culligan Mark 412 Softener?
    By dodgent in forum Water Softener Forum, problems, installation and reviews
    Replies: 7
    Last Post: 01-07-2012, 06:09 PM
  2. Culligan Mark 812
    By MrGeminiMN in forum Water Softener Forum, problems, installation and reviews
    Replies: 6
    Last Post: 08-19-2011, 08:20 AM
  3. Culligan Mark 89 Water Softener timing problem
    By hamsat in forum Plumbing Forum, Professional & DIY Advice, Tips & Tricks
    Replies: 0
    Last Post: 07-19-2011, 05:29 PM
  4. Culligan Mark 812
    By 01jordyn in forum Water Softener Forum, problems, installation and reviews
    Replies: 7
    Last Post: 04-27-2011, 08:41 AM
  5. culligan mark 59. should i keep or fix it?
    By grumpy 040 in forum Water Softener Forum, problems, installation and reviews
    Replies: 7
    Last Post: 12-18-2010, 10:50 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •