(206) 949-5683, Top Rated Plumber, Seattle
Results 1 to 8 of 8

Thread: Green Sand Filter Issue

  1. #1
    DIY Junior Member timb's Avatar
    Join Date
    Oct 2011
    Location
    Akron, OH
    Posts
    4

    Default Green Sand Filter Issue

    I just purchased a house (was a foreclosure, so it sat vacant for awhile), and am learning all about the water system.

    It has a Well Pump, Pressure Tank, Soda Ash injector, Green Sand Filter, then the Softener. The Water treatment systems are all ClearWater and are 10 years old.

    I got everything all cleaned up and working, except for one issue with the green sand filter. It was not pulling from the brine tank during the regeneration cycle. I took everything apart on the system and cleaned it, the injector in the head of the filter, and the float mechanism in the brine tank. Now it pulls about 1 1/2 - 2 inches out of the brine tank during the cycle. I thought that was good, but the refill cycle fills it more than it takes. So it is overflowing. I looked closer during the pulling out cycle, and it pulled about the first half of the cycle, then it didn't for the second half. Nothing on the timer changed, so I don't know why that happened.

    Any ideas?

  2. #2
    DIY Member rjh2o's Avatar
    Join Date
    May 2011
    Location
    Michigan
    Posts
    75

    Default

    A greensand filter does not use "brine" to regenerate. It uses potassium permanganate (purple oxidizing chemical) to regenerate and re-oxidize the geeensand media. There should be a small 5 gallon tank (which holds the potassium permanganate).
    Why is there soda ash being injected? These could be fleck or autotrol valves.
    RJ

  3. #3
    DIY Junior Member timb's Avatar
    Join Date
    Oct 2011
    Location
    Akron, OH
    Posts
    4

    Default

    Yea, I knew it was potassium permanganate. I just thought "brine" was a universal term for the tank that has the chemicals.

    I have the 5 gallon tank sitting in a trash can right now because it is overflowing (hence it is not pulling enough during the regeneration cycle and refilling too much).

    The soda ash injection happens right after the well pump before the green sand filter. It is doing this to raise the PH to a stable level. I was told that if that wasn't there, the water would strip the green sand and eventually ruin it if the ph was too low. Without the Soda Ash, the ph is 6, with it, it is 7-7.2.

  4. #4
    DIY Senior Member mialynette2003's Avatar
    Join Date
    Nov 2010
    Location
    Ocala, Florida
    Posts
    666

    Default

    What type of valve is on the greensand? If seals are leaking during the draw cycle, it can lose it's draw or be weak. A plugged or restricted drain line could cause a lack of draw or weak draw. Usually if it draws for 3-5 min, it will draw until the valve changes positions. If it starts to draw and quickly loses it, it is most likely a drain problem.

  5. #5
    DIY Junior Member timb's Avatar
    Join Date
    Oct 2011
    Location
    Akron, OH
    Posts
    4

    Default

    Not sure what Kind of valve it has, it is a ClearWater unit. The Brine/Rinse cycle (step 2 of 4 of the regeneration) is 60 minutes. The timer does not move at all for that whole 60 minutes so it should pull the purple fluid the whole time right? It was slowly drawing for about the first 30 minutes, then stopped for the second 30 minutes. Over that first 30 minutes, it only pulled out about 1-2 inches out of the completely full brine tank.

  6. #6
    DIY Junior Member timb's Avatar
    Join Date
    Oct 2011
    Location
    Akron, OH
    Posts
    4

    Default

    I took apart everything and cleaned it. The jet, the part that plunges down and opens the line for the brine tank, the whole float mechanism in the brine tank. The only thing I didn't do was empty out the brine tank and clean it. Is that needed? What should I do with all the purple fluid if I do, and how much do I put back in the tank?

  7. #7
    DIY Senior Member mialynette2003's Avatar
    Join Date
    Nov 2010
    Location
    Ocala, Florida
    Posts
    666

    Default

    The unit should draw all the fluid out then the float seals preventing air from being drawn into the system. When the unit goes into a refill, it should put back the required amount of water. If the water gets close to the top then it is not pulling out all the water, the float is not properly set or the tank is filled with sludge and need it be cleaned. After cleaning, add water to very little above grid plate. Send me an e-mail and I'll send you the instructions for setting the float. affordablewtr@aol.com

  8. #8
    That's all folks! Gary Slusser's Avatar
    Join Date
    Aug 2004
    Location
    Wherever I park the motorhome.
    Posts
    6,790

    Default

    The 60 minutes draw sounds right without knowing what size filter it is or how much potassium permanganate it is supposed to draw.

    The water in the brine tank is sucked out in like the first 20-30 minutes of the 'brining' position (your 60 minutes) and then clear water is flushed through the mineral bed for the remaining time. Then the valve goes into a rinse. Backwash will be the first position and that is probably like 15-20 minutes.

    You set the float for the number of ounces of PP used.
    Gary Slusser Retired (= out of business)
    Click Here to learn how to correctly size or program a water softener.
    CAUTION, as of Nov 12 2013 all YouTube videos showing how to rebuild a Clack valve have an error in them that can cause damage.

Similar Threads

  1. Easy being green, Central PA Magazine August 2008 issue
    By Terry in forum Toilet Forum discussions
    Replies: 0
    Last Post: 04-04-2010, 08:47 AM
  2. green sand filter
    By B Skipper in forum Water Softener Forum, problems, installation and reviews
    Replies: 8
    Last Post: 03-13-2010, 10:15 PM
  3. Recommendation for Sand or Spin-down filter?
    By craftech in forum Pumps and Tanks Well Forum & Blog
    Replies: 11
    Last Post: 11-16-2008, 10:51 PM
  4. Sand now in filter
    By kennyp1960 in forum Pumps and Tanks Well Forum & Blog
    Replies: 1
    Last Post: 10-22-2007, 10:51 AM
  5. getting sand in filter
    By djarp in forum Pumps and Tanks Well Forum & Blog
    Replies: 4
    Last Post: 07-21-2006, 06:42 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •