I have a Kenmore UltraSoft 480 water softener, model number 635-388480. I am getting an error code, error 3, on the screen. I have tried using the manual and troubleshooting myself. I have gotten up to recharging it. It did not go into the fill cycle. It said backwash which the manual tries to explain but I get a bit lost at that point. I never say water flow into the brinewell. It then kept making a loud running water sound. I unplugged it and the sound continued. I plugged it back in and it started to recharge again but had no remaining time on it. It then said fill but still no water was running into the brinewell. I left it alone and when I returned it had error 3 on it again. Today I unplugged it again and plugged it back in and after a few minutes it started making that loud running water sound and got stuck there. I called Kenmore and he told me to push in the bypass thing. He said to replace these things in this order. First, the switch, then the wire harness, then the control panel. Sears said I can not return parts if they are not the right ones so I would like to know what is wrong before I replace it myself. The softener did not cost that much to pay the ridiculous fees that they will charge me to come out and then fix it. I try to do everything myself if I can. I was advised by the parts department to come to this site and have someone help me diagnose the problem before I buy the parts.