(206) 949-5683, Top Rated Plumber, Seattle
Results 1 to 11 of 11

Thread: Aqua tek water softener problem

Hybrid View

  1. #1
    DIY Junior Member reebz2003's Avatar
    Join Date
    Jan 2011
    Location
    Massachusetts
    Posts
    5

    Default Aqua tek water softener problem

    Hello,
    I recently moved into a house with a Aqua Tek water softener and a Rainsoft PH neutralizer system. The problem i'm having is that i have added salt to the tank and manually regenerated the system many time over the past couple months and the salt level has not changed. I checked the pickup tube in the basin and it didnt seem to be clogged. Any advice would be greatly appreciated. Thanks in advance.
    -Jon

  2. #2
    In the Trades Akpsdvan's Avatar
    Join Date
    Dec 2009
    Location
    Alaska
    Posts
    1,464

    Default

    From what I can tell they have used many different valves in their equipment over the years and today.
    One of the most likely reasons for brine level not to go down is an injector that is plugged and the brine pull can not be done.. A little more information on what valve that you have on yours would help in figuring out just why.

  3. #3
    DIY Junior Member reebz2003's Avatar
    Join Date
    Jan 2011
    Location
    Massachusetts
    Posts
    5

    Default

    I have the aqua tek softener model number CSI001.

  4. #4
    In the Trades Akpsdvan's Avatar
    Join Date
    Dec 2009
    Location
    Alaska
    Posts
    1,464

    Default

    Here is a link for Fleck control valves,,
    http://www.pentairwatertreatment.com/en-us/Home/
    Maybe the valve that you have is with in the list.
    Here is also a list of Clack valves
    http://www.clackcorp.com/water/controlvalve.htm
    Knowing what valve is giving the challenge helps in figuring out the reason for the challenge.
    Last edited by Akpsdvan; 01-21-2011 at 12:24 PM.

  5. #5
    DIY Junior Member reebz2003's Avatar
    Join Date
    Jan 2011
    Location
    Massachusetts
    Posts
    5

    Default

    Thank you for link! From looking at the diagrams i believe i have the 1500 model from Fleck.

  6. #6
    In the Trades Akpsdvan's Avatar
    Join Date
    Dec 2009
    Location
    Alaska
    Posts
    1,464

    Default

    Brass body with the in at the back and out at the top, body looks be one piece?

    In any event the brine injector block on top of the valve body is the place to start looking and cleaning.
    If you have not down loaded the 1500 or 2510 book , do so..
    Under the metal cap is the injector that can plug, a small paper clip straightend will work to clean out the injector and then make sure that the screen is clean.
    Let us know if that works , pm is you need to ... other wise the fleck book should be able to walk you through most challenges with the valve.

Similar Threads

  1. salt for Aquafine Aqua 2 water softener
    By Juder in forum Water Softener Forum, problems, installation and reviews
    Replies: 2
    Last Post: 01-02-2011, 11:46 AM
  2. Aqua Therm heating system problem
    By Old Coot in forum HVAC Heating & Cooling
    Replies: 2
    Last Post: 12-14-2009, 08:14 AM
  3. What's the better water softener? Fleck5600SXT or Aqua System Smart choice.
    By ryan_siefring23 in forum Plumbing Forum, Professional & DIY Advice, Tips & Tricks
    Replies: 3
    Last Post: 09-08-2008, 11:46 AM
  4. Water Softener problem
    By bjp in forum Plumbing Forum, Professional & DIY Advice, Tips & Tricks
    Replies: 2
    Last Post: 09-04-2008, 07:40 AM
  5. Water Softener Problem
    By readytoroll in forum Plumbing Forum, Professional & DIY Advice, Tips & Tricks
    Replies: 1
    Last Post: 12-01-2006, 04:21 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •