(206) 949-5683, Top Rated Plumber, Seattle
Results 1 to 6 of 6

Thread: Check Valve Problem - I think?

  1. #1
    DIY Junior Member
    Join Date
    Dec 2009
    Location
    Racine, WI
    Posts
    12

    Default Check Valve Problem - I think?

    I installed a high quality check valve near the base of my sump pump - its not one of those flapper check valves. It worked perfectly. Really quite, no backflow at all. Then, I installed a battery backup pump and I used the same style check valve near the base of that pump. Now, when the main pump shuts off, its like I have no check valves at all. The whole system gurgles and you hear water and air moving back through the pipes. I tried multiple positions for the check valves, and nothing helps at all. If I disconnect the battery back up and plug the pipe, everything is fine - no noise at all.

    What could cause this. Its not a faulty check valve, because I've tried several of them and it makes no difference. Any ideas on this?

    Thanks.

  2. #2
    Test, Don't Guess! cacher_chick's Avatar
    Join Date
    Jan 2008
    Location
    Land of Cheese
    Posts
    3,161

    Default

    Hard to say without seeing it... posting a picture of your installation might help.

  3. #3

    Default

    Quote Originally Posted by lbk View Post
    I installed a high quality check valve near the base of my sump pump - its not one of those flapper check valves. It worked perfectly. Really quite, no backflow at all. Then, I installed a battery backup pump and I used the same style check valve near the base of that pump. Now, when the main pump shuts off, its like I have no check valves at all. The whole system gurgles and you hear water and air moving back through the pipes. I tried multiple positions for the check valves, and nothing helps at all. If I disconnect the battery back up and plug the pipe, everything is fine - no noise at all.

    What could cause this. Its not a faulty check valve, because I've tried several of them and it makes no difference. Any ideas on this?

    Thanks.
    I have the same problem. Did you drill in a small hole in the discharge pipe just above the main pump and below the check valve. I did and that still didn't help. Wonder if you need another hole on the backup pump?

  4. #4
    General Engineering Contractor ballvalve's Avatar
    Join Date
    Dec 2009
    Location
    northfork, california
    Posts
    3,261

    Default

    Are you sharing one outlet pipe?

  5. #5

    Default

    One pipe for each pump that y into a common discharge pipe.

  6. #6
    General Engineering Contractor ballvalve's Avatar
    Join Date
    Dec 2009
    Location
    northfork, california
    Posts
    3,261

    Default

    Do a search for Zoeller sump pump installation diagram. Find it in PDF. The check valves should be designed for sump pumps and above the basin. The 3/16 hole should be drilled about even with the pumps "top", and kept open.

    Describe this high quality check valve you have. Take a look at Dean Bennet supply for a good look at a Zoeller check valve.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •