(206) 949-5683, Top Rated Plumber, Seattle
Results 1 to 8 of 8

Thread: Kenmore Ultrasoft 425 Err3 Code

Hybrid View

  1. #1
    DIY Junior Member Nala81399's Avatar
    Join Date
    Mar 2010
    Location
    Arizona
    Posts
    2

    Default Kenmore Ultrasoft 425 Err3 Code

    I have a 4 year old Kenmore Ultrasoft 425 water softener that just recently has stopped working and displayes error code Err3. I have gone through some of the troubleshooting diagnostics in the manual with out success. I think I have narrowed it down to the valve position being the problem but am unsure of what could cause it... The switch or the actual PWA. I can see the switch indicator opening and closing as the valve rotates however the valve position indication always reads Serv. I never see it toggle between the other modes (Fill, Brine, Bkwash & Rinse). Any insight would be much appreciated.

    Thanks

  2. #2

    Default

    When the micro switch opens and closes and you see it on the PWA, the switch and wire are good. If the PWA does not show the valve changing cycles, the PWA is bad.

  3. #3
    DIY Junior Member Nala81399's Avatar
    Join Date
    Mar 2010
    Location
    Arizona
    Posts
    2

    Default

    Thank you for the response!

  4. #4
    In the Trades Akpsdvan's Avatar
    Join Date
    Dec 2009
    Location
    Alaska
    Posts
    1,464

    Default

    Is the motor bad?

  5. #5

    Default

    Quote Originally Posted by Akpsdvan View Post
    Is the motor bad?
    I didn't think the motor was bad because the OP stated he can see the micro switch open and close.

  6. #6
    In the Trades Akpsdvan's Avatar
    Join Date
    Dec 2009
    Location
    Alaska
    Posts
    1,464

    Default

    So if the motor is turning, and that metal wheel is turning, but no changes to the read out? Then I would say that the control board is bad.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •