(206) 949-5683, Top Rated Plumber, Seattle
Page 1 of 2 12 LastLast
Results 1 to 15 of 17

Thread: Help with Gould Balanced Flow Pump (BF03S)

  1. #1
    DIY Junior Member
    Join Date
    Feb 2010
    Location
    Trinidad
    Posts
    7

    Default Help with Gould Balanced Flow Pump (BF03S)

    Hopefully someone here can help me with this problem I'm having with my Gould BF03S balanced flow pump. The pump is used for supplying water at home from a 400 gallon water tank. Note that this pump is very old, about 30 years or so, but I am hesitant to replace it as it worked flawlessly for the first 20 year so so.

    When the pump was working perfectly, I had the cut-in set at 40psi and the cut-off at 50psi. Back then , the pump would turn on almost immediately after opening a faucet and turn off just as fast when the faucet was closed. For a fews years well the pump can just barely reach 35psi. I have a valve on the discharge line just after the discharge outlet. Even with this valve closed, the pump can hardly build up to 35psi, so I know it's not the rest of the plumbing.

    A few years aback, I changed everything inside the pump, the impella (which was cracked), the impella housing, venturi, nozzle, AVC line and valves and the AVC float. Even though I followed the guidelines for installing the AVC line and valves, the pump still could not build the 50psi or even reach 40psi. I followed the troubleshooting tips in the users manual but that did not help.

    Well, I've found myself in the predicament of having to replace everything again in the hope of solving this long standing problem with this really fantastic pump. This time I now need to replace the bearings for the motor also, which have failed after 30+years of service. This is why I am so hesitant on dumping this old pump and buying the new ones made by ITT. You just cannot get that type of quality anymore.

    So my question is this: Why can't the pump generate 50psi or even 40psi anymore? Back in the days, the pump's suction line was level with the water tank's discharge line. Since then, the pump has been raised about 9"-12". Honestly, I can't remeber whether or not the problem started when this was done. I will undo this only if I it is absolutely the cause of the problem.

    Please can anyone help me.

    Tanks.

  2. #2
    Previous member
    Join Date
    Jul 2009
    Location
    North of the Mason dixon Line
    Posts
    1,150

    Default

    Just for starters Goulds pumps are every bit as good, if not better today then they were 30 years ago, and I am still daily wearing shoes that are 30 years old

    Things wear out over time. Replace the pump and be done with it.

  3. #3
    DIY Junior Member
    Join Date
    Feb 2010
    Location
    Trinidad
    Posts
    7

    Default

    Well even if I did just replace the pump, I would still like to know what was causing the problem with this old pump?

    Or are you suggesting that I replace the pump simply because you don't know either? Either way, it will be a learning experiencing for us all.

  4. #4
    That's all folks! Gary Slusser's Avatar
    Join Date
    Aug 2004
    Location
    Wherever I park the motorhome.
    Posts
    6,790

    Default

    You rebuilt it once and that didn't solve the problem and now you need new bearings....which may have been going bad 20 yrs ago so how can anyone tell you what is wrong with it now or 20 yrs ago other than it has earned retirement and you'd be better of with a new pump? BTW, it only lasted 10 yrs before you had to rebuild it originally. So I suggest you replace it.
    Gary Slusser Retired (= out of business)
    Click Here to learn how to correctly size or program a water softener.
    CAUTION, as of Nov 12 2013 all YouTube videos showing how to rebuild a Clack valve have an error in them that can cause damage.

  5. #5
    General Engineering Contractor ballvalve's Avatar
    Join Date
    Dec 2009
    Location
    northfork, california
    Posts
    3,261

    Default

    If you can do it change the bearings, not a big deal. have you changed the seal? I say you have a suction leak of a minute amount - any air coming in will stop the pressure build up. Re-pipe all the inlet piping. If you are BELOW the 400g tank, raising it a few inches would not have hurt. If you are on suction feed what is the height? Your air leak could be in the housing you opened a few times also. Get nasty with lots of pipe dope or plumb it with flex hose and brass barbs... hard to leak.

  6. #6
    DIY Junior Member
    Join Date
    Feb 2010
    Location
    Trinidad
    Posts
    7

    Default

    Well thank you. Finally, it's not just about replacing the pump, it's also about solving the problem. What if the pump was just a few years old? Should I go ahead and replace it still? I'm just trying to find out what is causing the problem.

    I am presently in the process of doing the repairs. I've replaced the bearings and am in the process of re-assembling everything else. I did replace the seal everytime I opened the housing. Guess I'd do as you suggested and see what happens. Am being extra extra careful this time to eliminate any air leak.

    Thanks for the advice ballvalve. Will post back on the results.

  7. #7
    General Engineering Contractor ballvalve's Avatar
    Join Date
    Dec 2009
    Location
    northfork, california
    Posts
    3,261

    Default

    I have a multi-stage centrifical booster pump fed by a 3000 gallon cistern, and it happens to be about 6 psi below the tank. At the pumping station, the booster pump was at one time level or below this 6 psi static feed. For various reasons I moved the pump up about 2 feet above the feed line, and the outlet looped down to the pressure tank. So now I have the pump at the top of a "trap", even though it has a positive pressure feed, if ANY air enters this pump, it will not build pressure. I have had to add a valve above the pump and let it leak for hours before I can get back to a normal cycle.

    If you listen carefully you might hear "cavitation" of sorts, or air being swished about in the pump - then you can just turn it off and forget about pressure building up. So if your pump is above the static feed, or partial pressure feed, and it has air in it for some reason, or is sucking it in on the inlet lines, it may not be able to purge itself. Maybe you can add a riser above some port in the pump and allow it to bleed water and maybe air to get all back on line.

    Good on you to keep old machinery operating and not send it to the lazy mans scrap heap.

  8. #8
    DIY Junior Member
    Join Date
    Feb 2010
    Location
    Trinidad
    Posts
    7

    Default

    Maybe you can add a riser above some port in the pump and allow it to bleed water and maybe air to get all back on line.
    Well I'm not sure what you mean by the above but I know that the balanced flow pump controls the air via the AVC system.

    Anyway, I've just connected it up to a 600 gallon tank full of water using some flex PVC pipe to test the pump.. The inlet is level with the tank's discharge. I'm hitting 60psi, did not aloow the pump to go any higher though so it may go higher. Right now, it's set to cut-in at 40psi and cut-off at 55psi. So far so good. I'm gonna leave it off for about 30 mins to checks for any leaks. It appears to be holding the pressure at 54psi for the last 10 mins or so. Things look good so far.

    Once I'm absolutely sure the pumps fine, then I'll connect it back to the house plumbing and check. If I encounter any problems, then I know it's the plumbing and not the pump. Did find a leaky check valve on the plumbing though, so I'm gonna replace that in the mean time.

  9. #9
    General Engineering Contractor ballvalve's Avatar
    Join Date
    Dec 2009
    Location
    northfork, california
    Posts
    3,261

    Default

    Have you ever changed part numbers av015 nozzle, 4k5 diffuser and 5k3 seal?

    I just looked at that pumps diagram - very unusual set up! Sounds like you got it fixed anyway... another 30 years to go.

    I dont think the avc solves issues of suction leaks, however.
    Last edited by ballvalve; 02-16-2010 at 08:44 AM.

  10. #10
    DIY Junior Member
    Join Date
    Feb 2010
    Location
    Trinidad
    Posts
    7

    Default

    Yes, I have replaced those parts in the past and I did this time around also. In fact the only thing I did not replace this time were the motor, 1K1 tank and the 1K2 motor mount.

    Yes she works like new now.

    Just finished connecting it to the house plumbing and it works just great. So much for 'go replace the pump, it's OLD'.

    I have set the cut-in to 35psi and the cut-off to 55psi. Is this OK? The only thing is with only one faucet opened about 1/3, the pump cycles because the pressure is building up very quickly. I tried introducing a restriction on the suction line by opening the inlet valve to the pump about 1/2. This solved the cycling but then when you open 3 or 4 faucets (toilet flushes, kitchen faucet opened, shower on etc) the flow is too low so I needed to open the inlet valve fully. With these faucets opened, the pressure drops to about 30-35psi so the cycling stops. How can I stop the cycling with just one faucet opened even 1/2 way?

  11. #11
    Previous member
    Join Date
    Jul 2009
    Location
    North of the Mason dixon Line
    Posts
    1,150

    Default

    That's great. Glad it worked out for you. Being in business I tend to forget that it may indeed be more economical for someone to rebuild their own stuff rather than replace it. If I had to do the same procedure for a customer, between the parts and the labor it just would not be cost effective.

  12. #12
    DIY Junior Member
    Join Date
    Feb 2010
    Location
    Trinidad
    Posts
    7

    Default

    Exactly so, if I had to pay for this I would have of course simply replaced the pump since the cost of the parts was about 40% of the cost of replacing the pump.. But I'm a DIY'er and I love to repair things.

    I'm also in the service industry but more electrical/power related. I did learn a lot about pumps by doing this, did not realize it was such a technical piece of equipment, something I did not venture in on my previous repairs. But I was adamant in solving this problem this time around.

  13. #13
    Moderator valveman's Avatar
    Join Date
    Mar 2006
    Location
    Lubbock, Texas
    Posts
    4,156

    Default

    Because you can't install it between the pump and the tank with that type of pump, you cannot use a Cycle Stop Valve to stop the cycling. The best you can do is increase the pressure switch setting until the pump stops cycing with the one hose running. If you turn it up too much however, it won't be able to shut itself off when you close the faucet.

  14. #14
    General Engineering Contractor ballvalve's Avatar
    Join Date
    Dec 2009
    Location
    northfork, california
    Posts
    3,261

    Default

    You could run it 35 to say 75 or 80 if it does it easily, then install a pressure regulator that feeds the house at @ 40psi. You might get cavitation if you restrict the suction line. You should finish with a large drawdown.

  15. #15
    DIY Junior Member
    Join Date
    Feb 2010
    Location
    Trinidad
    Posts
    7

    Default

    Because you can't install it between the pump and the tank with that type of pump, you cannot use a Cycle Stop Valve to stop the cycling. The best you can do is increase the pressure switch setting until the pump stops cycing with the one hose running. If you turn it up too much however, it won't be able to shut itself off when you close the faucet.
    I did that, the pump goes up to 60psi si I adjusted the cut-off to just below this, but but the pressure still builds with the low flow and causes the cycling.

    Quote Originally Posted by ballvalve View Post
    You could run it 35 to say 75 or 80 if it does it easily, then install a pressure regulator that feeds the house at @ 40psi. You might get cavitation if you restrict the suction line. You should finish with a large drawdown.
    Yes I did notice the cavitation when I restricted the suction line. Excuse my ignorance with these pumping terminology, but what do you mean by 'drawdown'?

    Can I then assume that the cycling that's happening with a low output flow is not a problem with the pump? What about if I were to put a pressure tank on the discharge line of the pump to act as a buffer (reservoir) for low flow?

    I need to redo the plumbing this weekend together with the addition of a new water tank and a filter, so if I can add the pressure tank then I'll provide for this.

    Well people, this pump thing is so technical, I am really learning quite a bit, and I do thank you all for that.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •