(206) 949-5683, Top Rated Plumber, Seattle
Results 1 to 2 of 2

Thread: Need help setting up used Kinetico

  1. #1
    DIY Junior Member jetjunkie's Avatar
    Join Date
    Jan 2010
    Location
    Indiana
    Posts
    1

    Default Need help setting up used Kinetico

    Hello! I just acquired a slightly used Mach system and RO unit for our new home on a new well. Slightly used is approx 2 yrs old. It appears to be in great condition. I had the plumber out to the house this morning to hook the unit up and a few other things. He had everything connected and turned on the water. The pre filter began to leak a ton! We checked numerous time to determine if it was just not connected properly. No luck. The rubber seal appears to be in pretty good condition but my only guess is that it needs replaced. Can I order a replacement? Is there perhaps a different problem?

    Additionally, the "gear" in the head unit is either a 6 or a 9. I believe I need a 3 or 4??? If I remember correctly we have 3 parts of iron and either 10 or 30 of hardness. (I know kind of a range. I will try to determine what it really is). I think I need a 4 because I believe that is what the rep that came out and tested the water said. Can I get and install a new gear?

    Lastly, is there a fitting that will allow me to interface my RO unit to my manablock?

    Looking forward to the claimed glory of this unit!

    Thank you in advance!

    NG

  2. #2
    Previous member
    Join Date
    Jul 2009
    Location
    North of the Mason dixon Line
    Posts
    1,150

    Default

    I sent you a PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •