(206) 949-5683, Top Rated Plumber, Seattle
Results 1 to 3 of 3

Thread: Hose Bib - Slow to Flow

  1. #1
    DIY Junior Member keithplumb's Avatar
    Join Date
    Oct 2009
    Location
    Kent, WA
    Posts
    2

    Default Hose Bib - Slow to Flow

    I moved into a house built in 1997 and one of the annoying things was a hose bib off my garage that would sometimes turn on when the water turned on, and sometimes you would have to wait a few seconds to a few minutes for the water to flow.

    This and a little drip annoyed my, so I ripped out the old one and of course decided to upgrade the ball valve back in the garage to a quarter turn and redid everything. All new hardware so I figured this issue along with a few drips would be fixed. Well the drips were fixed but not the "slow to flow" issue. Anyone have any ideas what is causing this? I searched the forum to no avail.

  2. #2
    I&C Engineer (mostly WWTP) Lakee911's Avatar
    Join Date
    Aug 2005
    Location
    Columbus, OH
    Posts
    1,328

    Default

    Are you on a well? If so, any chance air is getting in the line and ending up there?

  3. #3
    DIY Junior Member keithplumb's Avatar
    Join Date
    Oct 2009
    Location
    Kent, WA
    Posts
    2

    Default

    Quote Originally Posted by Lakee911 View Post
    Are you on a well? If so, any chance air is getting in the line and ending up there?
    Just on a municipal water supply. Never had it happen anywhere else in the house or outside the house, just this one spot.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •