(206) 949-5683, Top Rated Plumber, Seattle
Results 1 to 2 of 2

Thread: Low Pressure / Shallow Well Pump

  1. #1
    DIY Junior Member
    Join Date
    Apr 2008
    Location
    Grand Haven, MI
    Posts
    4

    Unhappy Low Pressure / Shallow Well Pump

    Looking for some information on my new Sprinkler System, I just installed a new 2hp shallow well pump, I only have Zone 1 completed it consist of

    [6] Nelson 6000 Series Heads (Gear Drive) 3/4" inlet coming off of a 2" main to a 1-1/4" elbow reduced to 3/4 to the head"; inthe open part of the yard

    [12] Nelson small popups coming from a 2" main to 1-1/4" line with [12] inline 1-1/4"x1-1/4" x 3/4"[fipt] T's reduced to 1/2" head; near the house for the flower beds

    I turned on the pump got the pressure to 45-50 psi then opened the valve and it dropped down to 10-15 psi. The small popups seem to be ok but the gear drive units seem to be very low pressure and do not shoot very far, I beleive this has to do with the low pressure. I bought the extra HP pump hoping this would fix any issues with low pressure. What did I do wrong or did I forget something...I'm pretty new to sprinkler systems so please help.

  2. #2
    DIY Junior Member
    Join Date
    Apr 2008
    Location
    Grand Haven, MI
    Posts
    4

    Default

    Quote Originally Posted by sgw0989 View Post
    Looking for some information on my new Sprinkler System, I just installed a new 2hp shallow well pump, I only have Zone 1 completed it consist of

    [6] Nelson 6000 Series Heads (Gear Drive) 3/4" inlet coming off of a 2" main to a 1-1/4" elbow reduced to 3/4 to the head"; inthe open part of the yard

    [12] Nelson small popups coming from a 2" main to 1-1/4" line with [12] inline 1-1/4"x1-1/4" x 3/4"[fipt] T's reduced to 1/2" head; near the house for the flower beds

    I turned on the pump got the pressure to 45-50 psi then opened the valve and it dropped down to 10-15 psi. The small popups seem to be ok but the gear drive units seem to be very low pressure and do not shoot very far, I beleive this has to do with the low pressure. I bought the extra HP pump hoping this would fix any issues with low pressure. What did I do wrong or did I forget something...I'm pretty new to sprinkler systems so please help.
    UPDATE: I GOT THE SYSTEM IN, IT PUMPS GREAT LOTS OF PRESSURE AND WATER WHERE IT IS NEEDED, I REMOVED THE CHEAP CHINESE GALVANIZED PIPE FROM THE CHAIN HARDWARE STORE AND REPLACED IT WITH PVC FROM THE GALVANIZED PIPE COMING OUT OF THE GROUND TO THE PUMP AND THEN OUT TO EACH ZONE, ALL ZONES ARE CONNECTED PROPERLY AND THE TIMER IS SET CORRECTLY, MY ISSUE NOW IS THE PUMP IS LEAKING PRESSURE WHEN IT SETS FOR MORE THAN 30-50 MINUTES SO IT WILL GET TO A STAGE WHERE IT KICKS ON AND OFF CONSTANTLY BUT NEVER BUILDS PRESSURE WITH ALL THE VAVLES CLOSED. I CAN'T USE THE TIMER BECAUSE I CAN'T LEAVE IT ALONE FOR MORE THAN 30-50 MINUTES. IT IS LEAKING PRESSURE FROM THE PUMP HOUSING IT IS A PLASTIC HOUSING WITH PVC THREADED INTO IT...WATER DROPS COME OUT VERY SLOWLY WHEN ITS RUNNING AND ONLY AT THE 2 PORTS ON THE PUMP. WHAT KIND OF PRESSURE DO I NEED TO HOLD WHILE THE PUMP IS OFF? WHAT CAN I USE TO SEAL THIS PVC THREADS, IM CURRENTLY USING TEFLON TAPE AND WAS READING IN THE PUMP MANUAL NOT TOO USE ANY KIND OF PIPE PUTTY BECAUSE IT MIGHT DAMAGE THE PLASTIC HOUSING?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •