(206) 949-5683, Top Rated Plumber, Seattle
Results 1 to 2 of 2

Thread: Flack 5600 question

  1. #1

    Default Fleck 5600 question

    I have a problem with my Fleck 5600, I had a cracked "injector body" and I replaced that along with new O-rings. I went to turn the water back on and now it wants to fill up the salt tank and keep filling up the tank even in the "in service" position? I have searched and found a post about having to replace the "piston rod assembly and the plastic spacers and O-rings"? Along with a new "brine valve piston assembly" I have checked the O-rings and they seem to be seated but I can't figure this one out? Thanks!

    J
    Last edited by Sprink669; 04-05-2008 at 05:38 AM.

  2. #2
    That's all folks! Gary Slusser's Avatar
    Join Date
    Aug 2004
    Location
    Wherever I park the motorhome.
    Posts
    6,790

    Default

    About the only way I know of to crack an injector body is to over tighten the two screws, or not have the piece of tube that goes on the one screw as a spacer. That's unless the brine valve cracked it somehow.

    Now you should inspect the orings on the brine valve, it may be allowing a leak to the brine tank during service. You may have one on wrong or damaged.

    You'd have to look at the flow diagram to see if the seals and piston could cause it; I'm unsure if they would.
    Gary Slusser Retired (= out of business)
    Click Here to learn how to correctly size or program a water softener.
    CAUTION, as of Nov 12 2013 all YouTube videos showing how to rebuild a Clack valve have an error in them that can cause damage.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •