(206) 949-5683, Top Rated Plumber, Seattle
Results 1 to 2 of 2

Thread: water softener - not softening- please help!

  1. #1

    Smile water softener - not softening- please help!

    Hi,

    I was hoping that someone could help me- I have the clack WS1 valve and have had so much trouble with my water softener. Twice in the last year and a half the plastic tubing from my brine tank to the mineral tank has cracked or broken off. I replaced it and it worked fine for one month. now the water is hard again. I regenerated yesterday and the water is hard once again. The salt level does go down but the water is hard. the guy who installed it has been a problem since the beginning. when he first installed my tank he forgot to put the salt in it. then when he did there was always some type of residue on my hands after washing them. he finally replaced the mineral tank and the tubing keeps cracking or breaking.
    He said he would charge me to come out and I do not want to give him another dime since I have had so many problems.

    can someone please recommend what I should do to troubleshoot this?

    thank you so much!

  2. #2
    That's all folks! Gary Slusser's Avatar
    Join Date
    Aug 2004
    Location
    Wherever I park the motorhome.
    Posts
    6,790

    Default

    Quote Originally Posted by trammien View Post
    ... Twice in the last year and a half the plastic tubing from my brine tank to the mineral tank has cracked or broken off. I replaced it and it worked fine for one month.
    That's odd, in 21 years I've never seen or heard of this cracking but.. are the fittings being overtightened? Compression fittings are not to be tightened until they can't turn, that causes air leaks.

    That and stress on the brine line would/could cause this problem. And any crack in the tubing would cause air to be sucked instead of heavy brine so it would not suck water and that means it can not regenerate the resin and the water will come up too high in the brine tank and you get hard water.

    Quote Originally Posted by trammien View Post
    now the water is hard again. I regenerated yesterday and the water is hard once again. The salt level does go down but the water is hard.
    Then you need to regenerate it with the max salt dose lbs for the volume and type of resin in the tank. That's 15lbs/cuft of regular mesh resin. And then repeat that with as little water use between the two manual regenerations if any.

    Quote Originally Posted by trammien View Post
    the guy who installed it has been a problem since the beginning. when he first installed my tank he forgot to put the salt in it. then when he did there was always some type of residue on my hands after washing them. he finally replaced the mineral tank and the tubing keeps cracking or breaking.
    Residue... you mean as if you couldn't rinse soap off your hands? If so that means the water was soft; 0 gpg soft water. In 18 years as a local dealer, I rarely provided salt when installing a softener.... only for a rare customer that couldn't go buy their own and dump it in the tank. Then they would find someone else to do it for them.

    Quote Originally Posted by trammien View Post
    He said he would charge me to come out and I do not want to give him another dime since I have had so many problems.
    Yes a local dealer can't afford to run around for free, it costs too much but he should find the cause and make it right regardless of what it costs him. So it is best for most people to become self sufficient, or independent and DIY.
    Gary Slusser Retired (= out of business)
    Click Here to learn how to correctly size or program a water softener.
    CAUTION, as of Nov 12 2013 all YouTube videos showing how to rebuild a Clack valve have an error in them that can cause damage.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •