(206) 949-5683, Top Rated Plumber, Seattle
Results 1 to 7 of 7

Thread: In Floor heating system's Thermostat

  1. #1

    Default In Floor heating system's Thermostat

    Hi there
    I would like some advice around the use of an infloor heating system's thermostat (Easy heat). 2 years ago we installed an infloor heating system with a sensor wire into the mortar underneath the tiles. The thermostat is a 7 day programmable one. To this day we have not done anything to the tiles that could have damaged the sensor wiring (such as drilling etc)

    For the first year the thermostat and the floor worked fine. Great heat on your feet. However, we turned it off for the summer months and when we turned it back on the reading on the thermostat that indicates actual floor heat went up to 120F even through the tiles are stone cold and no heat can be felt. There is no heater or anything near the sensor causing it to perhaps to read that temperature instead and making the thermostat go to the maximum level the floor can be set to. Because that is the maximum level, the heating systeme won't come on.
    Thinking perhaps the thermostat was defective we removed it and re-installed it thinking it would reset itself. No luck. So we replaced it with a new thermostat. This has not fixed the problem and the same is happening. At least it ruled out tha thermostat as a cause. We were able to get the floor to warm up, although the temperature was appr 86 or so, the thermostat required to be set higher in order for the heat to go up to a nice temperature. It seems to be that for some reason the thermostat receives a "message" that the floor is at the maximum hear even though that is not the case. So it is back up at 120 and no heat coming on as a result of that.
    Does anyone have any idea what might be going on? The sensor has not been touched or the floor drilled in or anything. The fact that the heat did come on for a while tells me it all is working but somehow the temparture readings are not correct. All the components are easy heat. We called them but did not receive any call back after several attempts, let alone advice on what the issue could be.
    Karen

  2. #2
    Electrician Chris75's Avatar
    Join Date
    Aug 2007
    Location
    Litchfield, CT
    Posts
    608

    Default

    What does an "LO" reading on screen mean?

    * The floor sensing probe is damaged, missing or loose.
    * Call your electrician.

    What does an "HI" reading on screen mean?

    The floor sensing probe is reading a temperature over 104F.Probe is likely too close or is touching a heating wire inside the mat.The probe must be relocated. Call your tile setter to reposition the sensor.

    Since your thermostat is not displaying the above I would say your sensor is good also...

    EDIT
    Opps, sorry, that was for Nu-heat, not easy heat...
    Last edited by Chris75; 01-18-2008 at 03:06 PM.

  3. #3
    Electrician Chris75's Avatar
    Join Date
    Aug 2007
    Location
    Litchfield, CT
    Posts
    608

    Default

    Control showing much higher temperature than set.

    Problem with programmable thermostat, Return programmable thermostat to POP

    *or*

    Probe in direct sunlight or under obstruction

  4. #4
    Like an engineer alternety's Avatar
    Join Date
    Apr 2006
    Location
    Washington
    Posts
    636

    Default

    I am assuming you are talking about electric floor heating.

    If you substituted a known good thermostat, there is something wrong with (or in the path to) the sensor. Sensors should be placed in a small accessible tube so they can be replaced. Do that if it turns out to be bad. Make sure there is good contact by using an appropriate heat conducting goo (that is a technical term ).

    Are there any control electronics in the base attached to the electrical box on the wall. Does the thermostat directly control the power to the floor.

    Where are the physical wires from the sensor attached to the thermostat or the base. They might be loose or corroded. Remove, clean with a very fine sand/emery paper.

    If the thermostat is directly controlling the floor there is 120 V or 240 V present in that thermostat base. If you don't know how to handle that; call someone. You could get hurt and/or make pretty sparks until the breaker opens.

  5. #5

    Default

    I would talk to the Easy Heat folks and get some ohm readings for the sensor. Then put an ohm meter on the sensor wires to see what you have. I would guess a short in the sensor wires. Could be a bad probe, or a problem with the connecting wires. The wires could be shorted where they enter the thermostat box (more likely if you have a metal box) or could be squeezed tight elsewhere. If you can find a physical short you can fix it, if it is in the sensor you will have to find a way to place a new one, or go with an air reading thermostat which, I personally do not feel is a good way to go.

  6. #6
    Homeowner geniescience's Avatar
    Join Date
    Nov 2005
    Location
    humid summers hot, humid winters cold
    Posts
    2,152

    Default

    post again, karts.

    measure the resistance of the circuit without the thermostat.

    David

  7. #7
    DIY scratch-pad engineer leejosepho's Avatar
    Join Date
    Nov 2006
    Location
    200 miles south of Little Rock
    Posts
    2,474

    Default

    If your sensor is bad and you do not want to dig into the floor to replace it, something like this might be your solution as long as your heating wire is still okay:
    http://www.aubetech.com/products/pro...=51&noLangue=2

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •