(206) 949-5683, Top Rated Plumber, Seattle
Results 1 to 5 of 5

Thread: Shower faucet problems

  1. #1

    Default Shower faucet problems

    We recently had our tub enclosure tiled and the tilers didn't leave enough space to put the escutchen back in place, so I removed the faucet handle and figured I would nip away some of the tile. When I put everything back the way I thought it was supposed to go, the water doesn't turn off! There is hardly any difference between when the knob is in the up or down direction!

    I am including 2 images which may help. I think it is an old Delta model faucet, but couldn't find any markings. It is the single handle type, and has three holes (see image) I think there were washers and springs in all 3 holes but I couldn't swear to it because when I pulled the front off the springs came out and I could only find 2. So I went to the hardware store and bought a Delta replacement kit and thought it would be an easy fix, but it made no difference at all. So I hope I'm missing something obvious. Thank you for any help.
    Attached Images Attached Images   

  2. #2
    One who lurks Basement_Lurker's Avatar
    Join Date
    Jun 2007
    Location
    Victoria, BC
    Posts
    668

    Default

    Each hole should have a spring, and then a rubber seat on top of the spring that will make contact with the ball. The ball must be aligned correctly for the functionality of the ball setup to work properly. Here's a diagram of your setup so you can see if you are missing parts:

    http://wcmprd1.deltafaucet.com:9081/...5/exploded.gif

  3. #3

    Default Thanks, and more info needed.

    Thank you for sending me the diagram. As you see from my image, there are three holes in the inner assembly. Do only the 2 side holes have the washer and spring? I put the washers in the two side holes and do I put the springs in there also, or do maybe the springs go in the ball set? And which way do the springs face, with the small side in or the large side in? (They are cone shaped) I tried it both ways but can't get the springs to stay if I put the large side in.

    Sorry for all the questions, but I don't know what all this is supposed to look like!

  4. #4

    Default

    You only need to use the seats and springs in the two side holes. Isn't that how it was when you took it apart? Insert the springs in the two holes and put the rubber seats over them.

    Next, you must install the ball valve correctly. In most Delta valves, there's a little protruding guide post to help orientate the ball valve to the correct position. If yours dosn't have one, you'll need to experiment with putting it in, 'til you get it lined up properly.

    Then, you must install the plastic v-shield, with the protruding side facing the groove in the valve.

    Then, you must install the metal cap and trim.
    Last edited by Verdeboy; 08-05-2007 at 02:24 PM.

  5. #5

    Default Thank you!

    When I took the thing apart, the springs sprung, so I didn't see how they were originally configured. I put the rubber seats in first, since they fit in there so nicely. Doing it your way worked much better! It's all put back together and working fine. Thank you again.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •