(206) 949-5683, Top Rated Plumber, Seattle
Results 1 to 4 of 4

Thread: No Soft Water

  1. #1

    Default No Soft Water

    I have a Kenmore water softener that was run out of salt. Not a new thing. This time after refilling the salt and regenerating a few days there still is no soft water. Everything seems to be working correctly in the regeneration cycle but still no soft water. Ideas??

  2. #2
    In the Trades kordts's Avatar
    Join Date
    Oct 2005
    Location
    exurban Chicago
    Posts
    551

    Default

    Call Sears, if it's still under warranty. I myself use an independant treatment guy to test water and design the systems. Your salt setting may be too low. It may need to be set to regenerate more often.

  3. #3
    DIY Senior Member SteveW's Avatar
    Join Date
    Feb 2005
    Location
    Omaha, NE
    Posts
    1,042

    Default

    You probably have a water heater full of hard water. It will take a while to refill with soft water.

  4. #4
    That's all folks! Gary Slusser's Avatar
    Join Date
    Aug 2004
    Location
    Wherever I park the motorhome.
    Posts
    6,792

    Default

    Is the water in the brine tank higher than normal?

    Is there water running to drain in a regeneration?

    Check the operation and troubleshooting sections here:
    www.kenmorewater.com.
    Gary Slusser Retired (= out of business)
    Click Here to learn how to correctly size or program a water softener.
    CAUTION, as of Nov 12 2013 all YouTube videos showing how to rebuild a Clack valve have an error in them that can cause damage.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •