(206) 949-5683, Top Rated Plumber, Seattle
Results 1 to 12 of 12

Thread: Rheem Power vent 2

  1. #1

    Default Rheem Power vent 2

    I bought a rheem powervent 2 hot water heater from home depot back in September, and it has worked fine till today. I came home and no hot water so I
    check and find the burner is off. I reset the water heater (unplug and plug back in) venter motor and burner come on, so I thought it should be fine...not!

    then I hear a dripping noise in the heater, I removed the covers and find small drips of water dripping on to the burner.

    my question: is the tank gone or is there something i can do.

    oh and I will contact rheem on Monday for Warranty.

  2. #2
    Master Plumber master plumber mark's Avatar
    Join Date
    Feb 2005
    Location
    indianapolis indiana - land of the free, home of the brave....
    Posts
    4,244
    Blog Entries
    1

    Talking sounds bad to me

    well you sound like you got a bad one....

    call them up , they will give you a new one...


    but you got to do the labor....

  3. #3
    In the Trades GoTanklessToday's Avatar
    Join Date
    Jan 2007
    Location
    Renton, WA
    Posts
    89

    Default

    The dripping you are hearing is likely condensation. Let the tank come up to temperature and see if the dripping stops. Will the burner stay lit now until the stat is satisfied?

    Check for obstructions in the vent, bird nest, tennis ball, other junk.

  4. #4

    Default

    Yes the dripping has stopped, and the stat gets satisfied. the vent seems clear.
    does condensation usually go back to the burner?

    p.s. Thanks for the reply GoTanklessTODAY.
    Last edited by superheat; 01-27-2007 at 10:36 AM.

  5. #5
    In the Trades GoTanklessToday's Avatar
    Join Date
    Jan 2007
    Location
    Renton, WA
    Posts
    89

    Default

    As I'm sure you know, there is a flue going up through the center of the tank. Since the hot water was depleted in the tank, and the lockout didn't allow the heater to fire, you ended up with a big metal tank full of cold water. As soon as you reset the module, the heater fired, and now you are applying a huge flame to all that cold water. It's the same as taking an ice cold glass of Iced Tea outside on a 100 degree day. Condensation forms and drips. In your case, it drips down the flue and onto the burner assembly. Sometimes is drips strategically enough to cause a problem with the HSI, or spark ignitor which also acts as a flame sensor. It can be a matter of re-aligning the flue baffle, or re-orienting the heater somewhat to get a different angle if the floor is not quite level.

  6. #6
    Master Plumber master plumber mark's Avatar
    Join Date
    Feb 2005
    Location
    indianapolis indiana - land of the free, home of the brave....
    Posts
    4,244
    Blog Entries
    1

    Talking condensation

    This would still be someting to keep an eye on for a while...

    perhaps it is condensation, and it will all just go away......

    but then again something made your heater shut off and

    it takes a lot of condenstion to accomplish that....

    a small pin hole leak is still a possibility...


    keep your fingers crossed... .....

  7. #7

    Default

    Thanks for all the replys guys!

    The problems has gone away on it's own and the tanks works normally.

  8. #8

    Default New problem with the same water heater

    the other problem is totally gone, but now another problem.

    The burner lights, heating the water. after about two minutes with the burner on
    there is a loud noise that sounds like a large transformer powering up or like twisting metal sound. I can't locate were the sound is comming from.

    what is the order of operations after the burner lights?

  9. #9
    Master Plumber Dunbar Plumbing's Avatar
    Join Date
    Apr 2005
    Location
    Northern Kentucky/Greater Cincinnati Area
    Posts
    2,943

    Default

    Quote Originally Posted by superheat
    the other problem is totally gone, but now another problem.

    The burner lights, heating the water. after about two minutes with the burner on
    there is a loud noise that sounds like a large transformer powering up or like twisting metal sound. I can't locate were the sound is comming from.

    what is the order of operations after the burner lights?

    Go to Rheem's website and either open the PDF on the troubleshooting charts or look in the book that came with your water heater on the side of the tank.

    Is this a GE Rheem PowerVent? I'm having all kinds of problems with these tanks. People call me up like it's my fault which is BS. I just installed it, didn't make it.

    An authorized rep has to come out and determine what is malfunctioning. I believe everything is covered the first year and from there on out.....only the tank is covered.

    None of those other parts are covered I believe. It would be better if your tank was leaking. I just replaced one that did just that, 2 years old and the customer basically paid for an install twice. Not good for the customer.
    Read what the end of this sentence means.

  10. #10
    Master Plumber master plumber mark's Avatar
    Join Date
    Feb 2005
    Location
    indianapolis indiana - land of the free, home of the brave....
    Posts
    4,244
    Blog Entries
    1

    Talking Defective Thermostat...

    You sound like you have a defective thermostat....


    I had one that was bad from start about two months
    ago....


    Their is a magnet inside that t-stat that chatters something awful.........very loud.

    probably have to call the factory and have someone come out and change it out.


  11. #11
    DIY Junior Member badluckguy's Avatar
    Join Date
    Jul 2011
    Location
    Cicero, MI
    Posts
    1
    Blog Entries
    1

    Default rheem power vent2

    Plz help... I don't know wats wrong with my boiler. I noticed that I wast getting cold water now for three days. And no hot water at all.. so after three days I finaly reset it .. ( I unplug it) it turned on an everything was fine but it just stays on for 2mins. Then it turns off. Then I hear several clicking noises but the burner won't turn on .after several clicking noises the led light turns on an it flashes 4 times .. then it pauses then it flashes again 4 more times.. What should I do .....

  12. #12
    In the Trades Gary Swart's Avatar
    Join Date
    Sep 2004
    Location
    Yakima WA
    Posts
    7,246

    Default

    Call a Rheem repairman. Not all jobs are DIY friendly especially if you don't have a clue about what you are doing.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •