(206) 949-5683, Top Rated Plumber, Seattle
Results 1 to 15 of 25

Thread: Pumptrol problem

Hybrid View

  1. #1

    Default Pumptrol problem

    Ok, first off... I'm just learning about my well. My experience with my well is that I've replaced my pressure tank. That's it.

    Now for the first problem. I have a 120 gallon pressure tank with gauge, a pumptrol sitting on top of a brass check valve that reads Flowmatic, and an air valve threaded into the brass check valve. Ok, I noticed awhile back that when the pump kicks on there a large trickle of water that comes from that air valve. Then when the pump turns off I hear an air sucktion that lasts for awhile. Is this normal? Or does it need replacement?

    Second problem, started yesterday. I noticed the water pressure was low...extremely low. Walked out to the well and the tank was sitting at about 15psi. Took off the pumptrol cover and bumped the connection with the cover. Pump kicked on and pressure went back up to 60psi. This morning same thing. Low pressure. Bumped the connection and all was well. I ran the water in the house to see what happened and it went down down down...
    But I walked out to the well and the pump was charging the tank.
    The well is around 11 years old and the only thing that's been replaced is the tank. What do I need to do?? Where can I get parts for this??


    -DD

  2. #2
    Rancher
    Guest

    Default

    Quote Originally Posted by ddeblance
    Now for the first problem. I have a 120 gallon pressure tank with gauge, a pumptrol sitting on top of a brass check valve that reads Flowmatic, and an air valve threaded into the brass check valve. Ok, I noticed awhile back that when the pump kicks on there a large trickle of water that comes from that air valve. Then when the pump turns off I hear an air sucktion that lasts for awhile. Is this normal? Or does it need replacement?
    Ok it sounds like you have a standard pressure tank, no bladder. The air valve (sniffter valve) should not leak water, order another one from http://www.pumpsandtanks.com It will suck air in when the pump stops, this is where your air cushion in the pressure tank comes from.
    Quote Originally Posted by ddeblance
    Second problem, started yesterday. I noticed the water pressure was low...extremely low. Walked out to the well and the tank was sitting at about 15psi. Took off the pumptrol cover and bumped the connection with the cover. Pump kicked on and pressure went back up to 60psi. This morning same thing. Low pressure. Bumped the connection and all was well. I ran the water in the house to see what happened and it went down down down...
    The Pumptrol is a pressure switch, it is either not seeing the pressure drop (plugged 1/4" pipe), or the contacts need cleaning. You probably should just buy another one from that same place.

    Rancher
    Last edited by Rancher; 12-29-2006 at 09:01 AM.

  3. #3
    Previous member
    Join Date
    Jul 2005
    Location
    Riverview, Fl.
    Posts
    4,540

    Default

    If you were here in Florida I would say spray around the switch with bug spray every few months to keep the ants from getting between the pressure switch points. Half of our service calls are to remove ants from switches. This does not mean a new switch is always needed, usually the ant will burn up and the switch will go back to working. If the points look slightly burnt, that is normal, if they are all black and nasty looking, you might want to change it. Like Rancher said, it could be a plugged pipe feeding the switch also.


    bob...

  4. #4

    Default

    Sorry for misleading... Like I said, I'm new. The tank is a bladder tank
    I live in Southeast Texas so the ants are bad. I try to keep ant killer around the well, but I know when they get in because the pressure drops. And thats what I thought the initial problem was. But I checked and there is ants in the bottom plate of the pumptrol, but nothing in the contacts or mech. I try to keep it clean as possible. I've looked for parts but all I can find is the pumptrol. Can't find the brass check valve with the threaded hole for the sniffer valve. That's what it has now. I figured since I have to clean my shower heads and replace screens in faucets about every six months then it's probably building up in my well components also......


    By the way while your answering my question. Does the tank have to be next to the well or can I move it? Liek right now my well sits out about 100 yards from my house. So I have this blue tank sitting in the middle of my yard. The water line comes around the side of my house to the back and in. Can I move the tank next to the back side of the house where the water comes in????


    Thanks for the help..
    -DD
    Last edited by ddeblance; 12-29-2006 at 10:01 AM.

  5. #5
    Previous member
    Join Date
    Jul 2005
    Location
    Riverview, Fl.
    Posts
    4,540

    Default

    If you have a bladder tank now, you need to plug the hole that the schrader valve is in. You will have spitting of air in the house if you don't.

    bob...

  6. #6

    Default

    Well, it did get air in the line awhile back. I pulled the valve off and cleaned the build up off of it and that stopped. But it still pools water when the pump turns on. I get some air when the bladder tank drops in pressure.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •