PDA

View Full Version : Mystery flushes



hollybegonia
08-03-2012, 02:40 PM
Hi. We have three Sterling 1.6 GPF toilets. They're all about 10 years old.
One of them recently began to flush mysteriously on its own from time to time.
My husband just tried to repair it using a Fluidmaster Universal Complete toilet kit.
Unfortunately, we just heard it flush again on its own. This is not happening as often now, but something else is obviously amiss. BTW, the floor around the toilet is dry. Ideas? (There it goes again!)

Terry
08-03-2012, 03:09 PM
Sterling uses a slightly larger flapper on their flush valve.
If you installed the new Fluidmaster flushvalve, then that would be solved. Make sure that the refill tube on the fill valve daylights above the overflow tube, or it can siphon the tank.

hollybegonia
08-03-2012, 04:14 PM
Thanks, Terry. My husband says he's done all that. All he can think of now is that he didn't seat it properly, so he's going to do the job over again. Could the kit have been defective?

hj
08-04-2012, 07:43 AM
Possible, but very unlikely. It is probably "user error", but doing everything over again is probably not the solution. How about a picture of the tank's interior.

hollybegonia
08-04-2012, 11:33 AM
Thanks for the replies.
My husband says he took it apart and noticed a small "blip" on the porcelain where the base of the flapper attaches. He saw water leaking from that spot. So he filed it smooth, then added waterproof silicon to ensure a good seal (sorry, still not sure how to add a photo here).
After this dries really well (24 hours), he plans to reinstall the flapper.
Fingers crossed.

hollybegonia
08-06-2012, 12:41 PM
That did the trick!