PDA

View Full Version : Toilet won't fill fast after quick power loss



mark1234
07-03-2012, 08:35 AM
For some reason, my toilet fills VERY slowly (takes about 15 minutes) ever since we lost power in the recent storms for just an hour. Once the power went back on, the toilet issue started. Seems too coincidental that it would not be related to the power loss/storm? Anyone have any suggestions as to whats wrong?

Thank you!!

DonL
07-03-2012, 10:21 AM
Do You have a well pump ?

Water softener ?

More details may help.

mark1234
07-03-2012, 10:43 AM
Nope...I live in a condo building. They have a back up gas generator. The building said our pump pressure was low but it's back to normal now and I'm still having issues...Here's a key factor I forgot to mention earlier: If I turn off the water knob behind the toilet while it's slowly refilling and then turn it back on, it fills up fast and normal. I have to do that everytime for it to fill at normal speed.

Terry
07-03-2012, 11:26 AM
You may have a Watts Floodsafe supply line. If so, replace it with a standard supply line.

mark1234
07-03-2012, 11:33 AM
Thank you...But why would I need to replace the supply line because of a storm and short power loss?

Gary Swart
07-03-2012, 11:57 AM
Terry's point is that the Watts Floodsafe supply lines often fail when there is a pressure surge. They are trouble waiting to happen. IF you have that kind of line, replace it with a regular supply line.

mark1234
07-03-2012, 12:00 PM
Oh wow excellent! Ok thank you both so much. I'll check when I get home.