PDA

View Full Version : Pressing question on a Ford Van



Cookie
01-14-2012, 05:29 PM
Got a question for you good people with knowledge of vans.

It is an E150 Ford 02, 6 cyclinder, with all gauges suddenly, not working.
Possible causes?

Thank you inadvance. :)

DonL
01-14-2012, 05:47 PM
Got a question for you good people with knowledge of vans.

It is an E150 Ford 02, 6 cyclinder, with all gauges suddenly, not working.
Possible causes?

Thank you inadvance. :)


It is a Ford ?.

Fix Or Repair Daily, It is operating normally.

LOL.


Ground to dashboard controls, Blown F150 fuse.

Cookie
01-14-2012, 06:26 PM
Actually, I agree with the Fix or repair daily, because I had a ford taurus which was so horrible. No matter what we did with the starter, replaced it several times, then a recall on it, used to be, I had to carry a rubber mallet and carry it, rap on it, if I shut the car off my " mistake." You left it running, at all times, lol. going thru the drive thru anywhere, bank, fast food, etc. I was glad we donated it... yes, we donated it.

But, his van has been good until, now. I said, maybe a fuse, he said, no, not a fuse. You sure about this Don?

I got a wager on it, lol.
A vegetarian pizza. MY favorite... :)

DonL
01-15-2012, 10:58 AM
If it is not a fuse then I would check the ground going to Instrument cluster.

Check the ground connection near the battery.

It would almost have to be a ground problem, for it to be affecting all the gauges.

He may want to verify 12Volts is making it to the Instrument cluster.

Cookie
01-15-2012, 02:49 PM
Thank you Don. I checked with him, and he said, their's no fuse, so, it must be something else. Sometimes, I think, a Clysdale might be a good idea, like my friend in NZ wants for transportation, lol.

DonL
01-15-2012, 03:31 PM
Thank you Don. I checked with him, and he said, their's no fuse, so, it must be something else. Sometimes, I think, a Clysdale might be a good idea, like my friend in NZ wants for transportation, lol.

There is a fuse, Everything is fused.

I guess it just is not blown.

The Ford F150 dash is known for bad solder connections. They may have the same problem on the E150.


I own 2 Fords and they keep me busy.

cacher_chick
01-15-2012, 05:08 PM
There are 2 fuses in the fuse box under the driver's side dash that feed various functions of the instrument panel.

Pounding on the top of the dash helps sometimes too, even if only to alleviate aggravation.

DonL
01-15-2012, 05:59 PM
There are 2 fuses in the fuse box under the driver's side dash that feed various functions of the instrument panel.

Pounding on the top of the dash helps sometimes too, even if only to alleviate aggravation.

LOL.

That is exactly how you fix it.