PDA

View Full Version : intertherm nordyne model feh-017ha-04



Lokii
10-30-2011, 07:50 AM
I have a intertherm nordyne model feh-017ha-04. To give you a little background and knowledge of my capabilities I have over 20 years of experience with aircraft electrical/electronic systems. I am the type of guy who will fix whatever is in my power to do so myself. On this HVAC unit I have already replace the outside unit blower fan and cap and the inside blower. The outside was 2 years ago, the inside was at the start of this summer. Now to today's issue. This morning I woke up to no heat. It has been working for the last week. I did some investigation and found that the coils were coming on and starting to heat but the fan wasn't kicking in and the coils were cutting off in just a few seconds. I tried resetting the circuit breakers and disconnecting the power inside the unit. I was able to get the blower to come on by turning the fan switch to on or with the a/c. I decided to pull it apart so I disconnected everything, pulled the blower assembly out and had a look at the coils and the electrical section. I connected the blower power with it outside of the system and tried it again. It seemed to work at this point so I put it all back together and it is now working. I am smart enough to know that I am not done with this. I am sure that something was up with whatever controls either the blower or the heat as a whole. Any ideas would be appreciated as I know I will have to revisit this soon. I am very sure I will be replacing the whole system in the next year with everything going on with it, but I am not quite where I can afford that yet.

jadnashua
10-30-2011, 10:57 AM
Sounds, conceptually at least, that there's probably a sticky relay that turns the blower on. I'd follow the path from the thermostat calling for heat, and trace it to where it tries to turn on the fan.