PDA

View Full Version : American Standard Smart Valve runs



totvos
11-09-2004, 10:40 AM
I came across a number of posts (http://www.terrylove.com/wwwboard/messages2/28610.html) on the "old" version of this site while Googling my hissing American Standard toilet. Since you cannot post to those threads anymore, I am posting this message as an update to future readers with the same problem.

I did a screen-cleaning procedure the other day per the maintenance instructions, and ever since, the toilet keeps hissing. That internal rubber seal with the thin little flap on it is SO temper-MENTAL. No amount of tweaking the cap and seals seems to fix the problem.

Anyhow, if you call American Standard, they will ship you a new Smart Valve free of charge, no questions asked. Evidentally this is an ongoing headache for them, so if you want to defer replacing the valve with a FluidMaster, you can get a free one that should work (for a while). Both the US and Canadian support people were willing to do this (I am in Canada).

hj
11-09-2004, 11:10 AM
Why would you even want to bother putting another one in? Eventually you will have to replace it with a 400A, so why not do it right now?

Deb
11-09-2004, 02:49 PM
But why would you want to? Call, wait, install a valve that may last only a day or maybe not work at all?????
My personal opinion is that it is silly (well actually I wanted to use a stronger word that this, but didn't) to keep replacing a poorly designed valve when a Fluidmaster 400A is so inexpensive.
Deb
The Pipewench

hj
11-09-2004, 06:26 PM
Asinine might have been a good subtitution, but maybe a grandmother has to be more gentile, or politically correct, than a grandfather.