PDA

View Full Version : Culligan water softener stuck on regeneration



shiv
04-21-2010, 05:31 PM
Hi,

An old problem has re-surfaced and I was hoping to get some advice. My Culligan water softener is stuck on regeneration. It is supposed to come on at 1pm and finish, I guess, 2 hours later. It is now 5:20pm and it shows no sign of stopping. The dreaded eror code "E1" is also showing. I have hit the by-pass valve for now. The last time this happened I called the service guy, who was extremely helpful. He told me that the valve was stuck, somehow got it working again (I remember him asking me to give it a good tap), and did not charge me anything! I have tried tapping on the same place, but not too hard as I do want to break anything! But it does not seem to help at all. Can anyone suggest anything else I could try before calling for service again?

The model seems to be a: "Culligan Medallist Plus Series 45 Water Softener with Soft-Minder Meter".

Thanks,

--shiv--

Akpsdvan
04-21-2010, 05:57 PM
Sounds like the piston is stuck or the brine piston is stuck...

How good are you with taking things apart and putting things back together?

Age of the unit?
Water? Iron ? hardness?

shiv
04-21-2010, 06:25 PM
Sounds like the piston is stuck or the brine piston is stuck...

How good are you with taking things apart and putting things back together?

Age of the unit?
Water? Iron ? hardness?

I know I would not be good at taking apart this thing! The water hardness in my house is very high (according to the Culligan technician). The unit is about 10 years old.

Akpsdvan
04-21-2010, 06:46 PM
If you are not good at a tare down of the valve it sounds like saddly time for the service tech... as either main or brine piston is stuck and the motor can not move it to the next spot.

shiv
04-22-2010, 07:41 AM
Thanks for the advice. Will do!