PDA

View Full Version : Low Water Pressure



nancy_huggins
09-11-2005, 11:03 AM
I had a leak in to connections of my OLD water heater. Both Hot & cold connections were replaced. Water is still filling up the small indents where the fittings attach to the top of the heater.
Before the leak was found I had great water pressure, now after replacement the water pressure in whole house is crappy and slow.
What is wrong?

jimbo
09-11-2005, 01:36 PM
First there should be no water accumulating on top of the WH. This indicates a leaky connection which must be fixed.

As to the pressure, if both all the hot and all the cold are affected, suspect a bad main shut off valve. Possibly a gate valve which failed to open all the way, or became clogged with age-old debris when distrubed.

Bob's HandyGuy
09-11-2005, 03:37 PM
Finally got around to replacing the 60 yr. old, whole house shut-offs in my place. An opportunity afforded itself when the main broke down the street last week and they had to cut the water. They were gate valves, one before the meter and one after. I broke the stem on the after meter one from trying to close for a repair years ago. They really get corroded when old and barely turn. I tried to clean up the intact one but it still didn't rotate easily. Replaced them with 1/4 turn ball valves. I also discovered that they never really tightened the jumper wire when they swapped meters 15 years ago. The electrical seems to be much improved now that it has a good path to ground.