View Full Version : Brine tank filling up with too much water

02-05-2010, 07:48 AM
Good morning everyone. I need a little help with my unit. I have a Culligan Medallist 8" (Model WG844). This unit is outdoors, at my well. It is on a slab, but I haven't built the pump house yet. The unit is three years old. The setup is as follows: I have two pumps/tanks, one pulling from the well, filling up an aerator, another pump/tank pulling from the aerator. My softener is set up after this pump.

I noticed my water not getting soft. Checked unit, found water above the salt. Salt level was about half the tank. I emptied the brine tank and cleaned it and the float assembly. Got it all back together, put some water in it and 2 bags of salt. Didn't have time to do a REG on Demand. That night it did a cycle. Next day, noticed some resin on ground at drain hose. Very small amount, not even a palm full. Brine tank seemed ok. Didn't noticed abnormal water level. House water still not soft though.

Nect day, I checked all settings and performed a REG on Demand. Here's what I have in the programmed settings:

Regeneration Time - 2:00am
Salt Dosage - 10 lbs
Backwash Time - 10
Brine Draw/Slow Rinse - 70
Days to Regeneration - 4

It backwashed for 10 minutes. Very slow water flow from drain hose. Didn't notice any resin carryover. Don't know what went on at brine tank at this stage. Water level had float keeping valve shut to brine tank. After 10 minutes, the brine draw cycle started. At this point, I decided to override the float. I pushed open the valve and I could hear some flowing. I disconnected the tubing from the float assembly and found low flowing water going into the brine tank. I set the tubing down outside the tank. This cycle lasted for 70 minutes. The next cycle lasted for 10 minutes. I didn't notice a setting for this. In this stage, the flow of water into the brine tank increased. The tubing was still disconnected, laying on a pipe about 2' above ground level. It went from a small stream not shooting more than a couple inches in the previous cycle to shooting out almost 8' into the yard. The flow from the drain hose was still very slow.

Culligan has me scheduled for next Friday. Understandably, the tech I talked to would rather come out and do the work. He said it could be a number of things, including the seal pack. At $100, just for the service call, I would like to fix the thing myself if I am capable. I have never messed with softeners before, but I was a boiler tech in my Navy days, a licensed boiler fireman for a few years after that and I am now running chemical distillation and vacuum reactors.

To me, it seems like the flow from the control valve to the drain is restricted, but I am not familiar with how much flow is normal. How is suction created to pull brine from the brine tank?

I apologize greatly for the length of this post. Just wanted to get all info out there.

Gary Slusser
02-05-2010, 10:26 AM
In slow rinse/brine draw it sucks water out of the brine tank and you have it going into the tank which is indicative of a bad seal and piston, or a stuck or leaking brine valve on the control valve. Either is going to add water to the brine tank when it shouldn't be as you found and enough water raises the float and shuts off the flow into the tank as it is designed to do.

Without regenerating (no salt brine suction) your water goes hard.

02-05-2010, 10:33 AM
Water "going to" brine tank in that 70 minute time frame?

Either the injector is pluged, or the screen and brine piston are not working right, O ring cut or screen pluged.

Backwash should be at 2gpm if not then , flow the drain line to the valve, there is what is culligans T and the part of it that goes into the valve is held there by a metal horse shoe, pull that straight up and out of the way. Then pull the drain line fitting out of the valve. Drain control plug is still in valve , small phillips head to remove , look inside to make sure that it is clear.

Brine piston and injector is a more challenging item. The injector is under the silver plate on top of the valve with the three phillp head screws. (best put unit in bypass and into a cycle) de-pressure the unit before removing the plate.

PM me if you would like.

02-06-2010, 06:09 AM
Thank you for the replies. I will check the drain control plug when I get home this evening and then let you know what I find.

02-08-2010, 03:18 AM
This is what I found when I took the drain off the control valve. That is a rubber piece in there. I didn't want to poke a small screwdriver in that tiny hole just yet. Is there a screw in there or is there another way to go about it?

http://img8.imageshack.us/img8/5935/0207001928a.th.jpg (http://img8.imageshack.us/img8/5935/0207001928a.jpg)http://img8.imageshack.us/img8/6117/0207001929x.th.jpg (http://img8.imageshack.us/img8/6117/0207001929x.jpg)

Gary Slusser
02-08-2010, 08:30 AM
See the three screws on the top there holding the piece of shiny metal, remove them, the injector and injector throat and screen are under there.

That rubber part is the DLFC (drain line flow control button) and as long as the hole is clear you don't need to do anything with it.

02-08-2010, 09:17 AM
Thank you. I will check it when I get home this evening. I am off the next two days. Hopefully, I will make some good progress.

02-09-2010, 11:18 AM
Here is what I found. The screen is definitely dirty and somewhat plugged. Could this be why the brine tank is filling curing wrong stage? Or is this an additional problem. Really looking forward to your reply. I feel like this is progress.

http://f.imagehost.org/t/0805/0209001401.jpg (http://f.imagehost.org/view/0805/0209001401)http://f.imagehost.org/t/0832/0209001401a.jpg (http://f.imagehost.org/view/0832/0209001401a)

02-09-2010, 11:35 AM
Here is what I found. The screen is definitely dirty and somewhat plugged. Could this be why the brine tank is filling curing wrong stage? Or is this an additional problem. Really looking forward to your reply. I feel like this is progress.

http://f.imagehost.org/t/0805/0209001401.jpg (http://f.imagehost.org/view/0805/0209001401)http://f.imagehost.org/t/0832/0209001401a.jpg (http://f.imagehost.org/view/0832/0209001401a)

The screen is one part of the challenge, when the metal plate came off, did water come up and out of the injector? where the screen came from?
If that screen is dirty, then there is a very good chance that the screen on the brine piston is also dirty and may be adding to the challenge.

The injector is a 2 part item, there is a smaller part that is in the larger part that you see with the 4 parts that hold the screen. It does all come out if needed, or you could use a paper clip .... straightend out and pushed down in the middle .

02-09-2010, 02:35 PM
When I loosened the metal plate, water did squirt out until the pressure relieved. I cleaned the screen real good and replaced it and did a REG on Demand and still the same problems. I will go out there now and try to take out the other part and clean it.

02-09-2010, 04:02 PM
To get to that brine piston with its screen is a bit of a pain in the butt..

There is one screw center on top, behind that white cam, the other screws(2) are under that metal plate that the cam is on. When the 3 are removed the brine piston will come out as the front control plate is removed.. careful... if it is plastic any twist could break it.

PM if you would like phone number.

02-09-2010, 07:04 PM
I really appreciate your help. I removed the screen again and this time I also removed the injector. Some stuff in there, but not plugged. I replaced everything and called it a wrap for the day. I am off again tomorrow. I will try your next suggestion then. What will I be looking for when I remove the front control plate?

02-09-2010, 07:48 PM
On the brine piston that is just under the cap that you removed , running from the control plate to just under that injector... there is a screen that is on the back half, there are 3 O rings on that either black or white plastic cage... there is the piston that will come out when the front control plate with motor and timer come off... that plastic piston will have 4 Orings...(I think, been awhile...)
I got some of it right....
Here are some photos..

02-10-2010, 11:09 AM
Ok. This is what I have. The brine piston came out fine. It has 5 o-rings and they look good. I removed that cap again and pulled the screen, then the injector, and then that next piece. It has two o-rings and loks ok, just dirty.

http://i.imagehost.org/t/0088/0210001400.jpg (http://i.imagehost.org/view/0088/0210001400)

02-10-2010, 11:28 AM
Items do look like they should be good, the blue item, make sure that it is clear.. you did check the cage for that brine piston?

If the brine piston end was tracking with the white cam and the brine injector piston area is clear and clean, then the only other spot that could be of a challenge is the Main Piston and Seal cage.. one of the O rings around the main piston has a cut, not in place..9955 the photo is of the main piston, the white seal is one of five.. one or more could be the reason for the fill of water to the brine tank when it should be pulling.

02-10-2010, 07:01 PM
The main piston and seal cage were easy to get to but tough to remove. Got it out and all the o-rings looked good, but there was alot of sliminess. I cleaned everything and reinstalled with no issues. I went back to the drain outlet and removed the drain nipple. The flow was weak there. After a minute or two the black rubber plug with the small hole in it shot out of the cavity. Flow from the drain was real good then. I let it flush for a while, then reinstalled the plug. Now the flow through the hole is over twice as strong as before.

Started a regeneration and it is now sucking from the brine tank. Thank you for all your help. It is greatly appreciated.

02-10-2010, 07:12 PM
Glad to hear the good news.
Now we have another story of what to do and how to do it for the next person that has a system and challenges like yours and how to fix it.

02-23-2011, 10:51 AM
Reviving an old thread.


Is the pic above from a Medallist (previous page)? Mine is different, I think. Maybe this one is slightly disassembled or something???

Mine has a top with hole for piston rod, 3 cages, a thick cage, 2 cages, and end end piece with four prongs. At least that's I I reassembled it.

The one pictured seems to have an extra piece between the 3rd cage and the thick cage. After that, it looks like its disassembled between the thick cage and the 4th cage, which is fine but what is inside there? It looks like and extension to the piston rod and plunger, a second plunger?

I am lost. Ugh!