PDA

View Full Version : Pegasus Problem



jonM
12-01-2009, 08:01 AM
Hi Guys,
I have a curious problem with a Pegasus shower only single handle unit that I installed for an outdoor shower (read "set in stone (well stucco)"). For the past two years the unit has worked perfectly. Last month the cold water just stopped. I have removed the cartridge and only hot flows- no cold. The flow stops are full open. I even tried blowing air into the cold line from the cold flow hole (with nearby hose bib full open) and nothing...

There is a large (1" or so) bolt head on the cold side of the unit that I haven't messed with yet.. it looks like it must be an adjustment access hole cover or ? .. maybe something there..

any suggestions or ideas??

Jon

jimbo
12-01-2009, 07:17 PM
Sounds like a balance spool, which is stuck. Call Peg/GB for parts.

jonM
12-02-2009, 07:48 AM
Balance spool? Would that be what is hiding behind the large bolt head perhaps? I'll go take a look...
Well, this is what I found..
http://www.terrylove.com/forums/images/attach/jpg.gif

The cold flows fine with the cap removed.

http://www.terrylove.com/forums/images/attach/jpg.gif
I cleaned out some crud from the top and sides of the insert and the cap, but the insert wont budge. Is there a way to remove it? Is this the mysterious Balance Spool that you've mentioned?

hj
12-02-2009, 05:54 PM
If it DID NOT come out when you removed the cap, it is broken. You have to get a new balance spool, (it is one piece and attached to the "cap"). Then extract that piece from the valve before installing the new one.

jonM
12-02-2009, 07:22 PM
Thank you. I must say you have been much more helpful than the guys at my local Home Depot... they just have no idea. And the old plumber there that I spoke with today said (while on duty and in uniform mind you) that I should "not have bought Pegasus because it is crap!"


Live and learn...

I'll fish out the broken spool and replace it with a new one if I can find it. If not, I'll open up the wall and install a Moen.

Jon

trojanhorse
03-17-2010, 10:20 AM
Where do I call for Pegasus Balance Spool parts. Can you give me some info, please. Thanks