PDA

View Full Version : Culligan softener problem



TLplumbGuy
09-01-2009, 01:39 PM
Hi Folks,

I hope someone here can help me out!

I have a Culligan Medalist Series automatic conditioner
(models 2000)
Manual:
Cat. No. 01882292
Rev. B 5/11/01
DCO #2527

The machine has been working fine for around 8 years or so.

Every once in a while because of power failure or such I need to call Culligan for help on re-programming the machine.

Over the past few years the regeneration time has been slipping and slipping.
It finally got to a time that was waking me up in the morning.

It happened a couple of weeks ago and I went down and tried to stop the regeneration by unplugging the power.
It kept regenerating, so I plugged it back in and went back up to bed.

When it happened again yesterday, once again I unplugged the machine, but it kept regenerating. This time I unplugged a couple of plugs that go into the circuit board (a big pink one and a smaller white one), thinking that this would stop the regeneration. It didn't.
I couldn't push in the Red water tab. I went back up to bed.

Today I called Culligan to help me re-set/reprogram the machine.
When a tech guy learned that my panel was showing an E2 error message he said I'd need to have a tech guy come over to my house to fix it!

Is there some way to reset the machine?
It was working fine before I unplugged the power and the other two plugs.

Thanks in advance!

Mark

Gary Slusser
09-01-2009, 07:16 PM
Yeah unplugging a control valve when a softener etc. is using water only prevents it from doing anything but using more water until it runs out of water, highly unlikely or, you shut the water off... and you can cause problems.

TLplumbGuy
09-01-2009, 09:54 PM
You can Google your model for yourself to try to find the manual for your specific model. Looking at this one, which seems close, "E2" says your motor is stuck. Plugging and unplugging in the middle of the regen may not have done good things for it.

http://www.eculligan.com/support/medallist2003.PDF


Yup, that's the model I have.
My manual doesn't show the error codes though.
It looks like my motor's stuck.

They quoted $100+ just to have a tech guy come over.
Do you think they can 'unstick' the motor or am I in for a large repair bill?

TIA

Gary Slusser
09-02-2009, 12:48 PM
It is what it is and you can't get parts anywhere but Culligan, so your choices are to have them come out to fix it, bypass it and use raw water or, buy a new softener.

TLplumbGuy
09-02-2009, 01:17 PM
It is what it is and you can't get parts anywhere but Culligan, so your choices are to have them come out to fix it, bypass it and use raw water or, buy a new softener.

I tried choice #4 Gary.

Yesterday afternoon, I used a wrench to bang in the Red hot water tab. That stopped the water from flowing.

I also unplugged the power from the unit, and this time the display went blank for the first time!

I was hoping that if I left it for a day that it might recover on its own.

Today, I went downstairs and banged the Blue cold water tab in, so the Red tab came out again.

The water started flowing again, right away.
Then I plugged in the unit and *BINGO*, it started blinking the time!
And a couple seconds later the water turned off!

I think I have a good chance of getting her to work now.
But I still need guidance in re-programming her.

Gary Slusser
09-02-2009, 01:45 PM
Very good.

Without knowing what data it asks you for, and how much resin you have, and the hardness and iron you have, I can't help you program it.