PDA

View Full Version : Leaking Moen Positemp



1guido
06-13-2009, 04:34 AM
Well it's time to turn to the experts, 6 months ago built a brand new shower. That's the good, the bad this stupid Moen shower valve. About every 6 weeks it starts to leak. Now about to call Moen for the 3rd time (4th cartridge) to have a new cartridge sent out. I cannot figure out why this is happening. The inside of the valve is spotless no solder, no burrs. When I install the new catridge it works perfectly for about 6 weeks. I do have well water, I also have an iron filter so no rust & the water softner works fine.

Short of replacing the whole assembly (which I really don't want to do) I am out of ideas.

Thanks for any help or suggestions

John

http://www.terrylove.com/images/moen1222.jpg

Moen replacement 1222 for the Posi-Temp Shower Valve

SewerRatz
06-13-2009, 07:52 AM
It sounds like your water is being aggressive to the rubbers. But do you have any other Moen faucets in the home? If so have you ever ran into this with them? If not then that rules out aggressive water. So it would sound like some issue just with the valve itself.

1guido
06-13-2009, 09:10 AM
The original bathroom had a Moen valve although it was not the posi temp, no leaks in 20 years. The kitchen sink faucet is also Moen. No drips there

The second bathroom has an American Standard tub & shower valve no problems there either. I spoke with Moen this morning they are going to send a new valve body & stem, I'm not sure why replacing the whole assembly would change anything since the problem appears to be inside the posi temp valve itself. But then again who knows

J