PDA

View Full Version : diverter valve vibrates



mick04u
05-23-2005, 12:12 AM
Hello all....hope you can help me. I have a 3 handle tub/shower faucet. Due to a leaking hot water handle, I replaced the hot water stem assembly. That fixed the problem, but then water was running out the tub spout when the flow was directed to the shower head. I then replaced the diverter stem (I have a compression faucet). After replacing, it solved the problem, but then a new problem surfaced. Now, when I turn the diverter valve to shower or tub, I get a vibration at the beginning that goes away when fully opened either way. I thought this may be the valve seat and attempted to remove. I attempted to remove with a seat wrench and in doing so, I seemed to have stripped the valve seat. I've tried to spray it with WD40, but it doesn't want to budge. At this point, it's too stripped anyway for the seat wrench to catch. I made sure all the washers were intact on the valve stem and reinserted, but still have the vibration. Is the valve seat the cause of the vibration when beginning my turn to divert the water from tub to shower or could it be another problem? It only seems to happen when diverting hot water alone and not cold water alone. Am I over looking something? If it is the valve seat for the diverter valve, how can I remove the valve seat now that it is stipped? If it is not the valve seat, what else can it be? Is my only recourse at this point is replacing the entire manifold assembly?
Please help!!

hj
05-23-2005, 10:32 AM
The diverter is a double seated stem, so it had washers both on the end and partway up the stem. In addition some have a thin plastic "sealing" washer by the upper seal. If that is loose after the diverter is installed it can vibrate. Hot water could also be expanding something causing it to vibrate. It is not likely to be the seat you stripped causing the noise.

mick04u
05-23-2005, 10:17 PM
The diverter I have is a Sayco. It does not have a thin plastic sealing washer but does have washers at end and part way up and another under the Bonnet nut. Nothing seems to be loose and all washers and stem are new. Any other thoughts?