PDA

View Full Version : Vent-Away doesn't flush completely



welmoed
08-26-2007, 10:59 AM
We purchased a house built in 1972; three of the four bathrooms have American Standard wall-mounted Vent-Away toilets. Two of them work fine; the third (in the master bathroom) has problems with incomplete flushing. The contents of the bowl don't clear with one flush; it sometimes takes three or even four flushes to completely clear the bowl. What can we do about this?
--Welmoed

Terry
08-26-2007, 12:31 PM
You may need to plunge or snake the toilet.

My mother has a A/S wall hung that needs plunging every so often.

http://www.plumbingpartsdepot.com/as4049.pdf

welmoed
11-10-2008, 07:24 AM
The situation with the toilet finally got so bad that we called in a plumber to snake the line. He found no obstructions and is getting us a price on replacing the unit. In the meantime, my husband has removed the toilet from the wall in order to see whether there is an issue inside the toilet trap that is blocking or minimizing flow. He even replaced the innards with a standard flushing mechanism, plugging the vent-away hole. The issue seems to be that there isn't enough power behind the flush to create the strong swirl.
Any ideas on what to try next? Replacement is going to be costly and we'd like to avoid it.

Terry
11-10-2008, 08:09 AM
http://www.terrylove.com/images/auger_01.jpg
This is the Closet Auger.
Most likely, the problem is in the trapway of the bowl.
I wouldn't have left the tank parts alone.

welmoed
11-10-2008, 10:59 AM
Problem solved!!!

Bob took the tank and bowl off the wall, gave them a thorough cleaning, and discovered what the problem was. Evidently, the seal around the ventaway portion had failed, creating an air gap during the flush, which led to a failure of the swirl. I'm not sure exactly where he plugged it up, but once he did, he put the whole thing back together, and it works like a charm. I'm so proud of him... he just saved us $1000 (cost of new toilet and installation).