PDA

View Full Version : problem with shower



jakesdaddy
02-21-2005, 09:01 PM
I have a 3 stem type setup on my tub. I think it's a Price Pfister...
One stem for hot; one for cold; and a shower diverter.
However, when I turn on the diverter, hardly any water comes thru the shower head. Is there a special way to adjust the diverter after taking it off?
Would replacing the diverter fix the problem? Any help is appreciated.

jimbo
02-22-2005, 07:42 AM
First thing to suspect is the shower head itself. Remove it, then turn on the water. It should be a gusher. If not, then remove the diverter stem and see if some debris is inside. On that PP, you will often find broken pieces of the old nylon diverter washer.

jakesdaddy
02-22-2005, 02:35 PM
thanks for responding. First thing I checked was the shower head. It's fine.
I took out the diverter and even redid the washer seat thing-a-ma-bob.
I have a feeling that the diverter stem itself was/is in an incorrect position.
After I take it off, should I turn it all the way to left effectively "opening it up" or all the way to the right which would put the stem into a closed position against the incoming water valve. ??

jimbo
02-22-2005, 07:25 PM
To reinstall open it up. You do not want the stem to bottom out against the seat as you tighten it into the body.

jakesdaddy
02-22-2005, 09:25 PM
I will try that tomorrow.
Kinda late to be banging around in the bathroom right now. :)
My wife would hate that, I'm sure. I will let you know how it goes. THANKS!!

jakesdaddy
02-23-2005, 06:34 PM
That suggestion partially worked. I get water spraying thru the shower head, but ALOT of water coming out the faucet as well. Could the hot & cold stems be adjusted incorrectly? Would taking them off and reinstalling them the way I did the shower diverter help the situation? Could I have the wrong seat size in the shower valve or even the wrong seat in the hot & cold valves? Argh.